Sign in with
Sign up | Sign in
Your question

Install OS on SSD, but have Window Personal / Program files on HDD

Last response: in Storage
Share
August 11, 2012 2:46:15 AM

Okay, I'm aware that there are stickies that contain links that may of answered my question, but know I went through each and every one of the links and none of them answer my question correctly.

I just installed my OS onto my SSD (C:) . In addition, I have placed the most important drivers I have and Chrome onto the SSD as well. Now I would like to install everything else on the HDD. Not a problem, I could just continue to manually change the file location. Only that's not what I want to do. I want to make it so that ALL of the programs files (with exception of a few) are on the HDD (J:) . In fact it should be default, and done in a way where it won't get confusing between the drives.

An idea I had... is there a way to so to say "Clone" the OS on both the C and J drives? That way I could set the default file locations for the J drive's User files and Program Files however the rest of the OS files work on C. I've tried some of the things I found in tutorials but it just screwed up my computer.

Help?

Thanks!
August 12, 2012 11:59:49 AM

That looks like it will work for the user folders, but what about the program files? How do of defaulting that onto the other drive?
m
0
l
Related resources
August 12, 2012 11:08:13 PM



I tried following these instructions:

1/ Open the Registry Editor by selecting Start > Run > Regedit.
2/ Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion.
3/ In the right pane, double-click ProgramFilesDir and change the path in the String Editor to the drive and folder you want (i.e. H:\Program Files). You must also modify the entry for ProgramFilesPath. If your path is H:\ like mine is, the path would be H:\Program Files
4/ Exit the Registry Editor and restart your computer. My understanding is that some programs still require installation in the C:\Program Files folder, but I haven't found any yet. said:
1/ Open the Registry Editor by selecting Start > Run > Regedit.
2/ Navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion.
3/ In the right pane, double-click ProgramFilesDir and change the path in the String Editor to the drive and folder you want (i.e. H:\Program Files). You must also modify the entry for ProgramFilesPath. If your path is H:\ like mine is, the path would be H:\Program Files
4/ Exit the Registry Editor and restart your computer. My understanding is that some programs still require installation in the C:\Program Files folder, but I haven't found any yet.


However, I tried installing Adobe Reader after restarting, and it installed here "C:\Program Files (x86)\Adobe\Reader 10.0" instead of here "D:\Program Files (x86)\Adobe". Followed it exactly. Shouldn't this be working? What did I do wrong?

Or would you prefer me to do the steps with the code instead?
m
0
l
August 18, 2012 3:40:19 AM

jackattack923 said:
I tried following these instructions:



However, I tried installing Adobe Reader after restarting, and it installed here "C:\Program Files (x86)\Adobe\Reader 10.0" instead of here "D:\Program Files (x86)\Adobe". Followed it exactly. Shouldn't this be working? What did I do wrong?

Or would you prefer me to do the steps with the code instead?


In reply to this, I have tried repeating to ensure that I properly editted the regedit, however everything seems to want to default download to C:. I'm going to try wiping to try the code one.
m
0
l
May 24, 2013 12:40:02 PM

jackattack923 said:
jackattack923 said:
I tried following these instructions:



However, I tried installing Adobe Reader after restarting, and it installed here "C:\Program Files (x86)\Adobe\Reader 10.0" instead of here "D:\Program Files (x86)\Adobe". Followed it exactly. Shouldn't this be working? What did I do wrong?

Or would you prefer me to do the steps with the code instead?


In reply to this, I have tried repeating to ensure that I properly editted the regedit, however everything seems to want to default download to C:. I'm going to try wiping to try the code one.


Let me start by apologizing for what may seem to be grave digging. But since Google pulled this page up in the top five for my (similar) inquiry, it seems reasonable that someone else may have the same problem next week too.
That said, I installed my OS on my SSD this morning, and then enabled my Raid drives (the only way I could find to keep the "oh so clever window's software" from substituting my "C" drive choice with the largest available hard drive.)
My point, and I do have one is that when I went to name the raid drive, I wanted to call it D. But it would not allow me, because D was reserved by the system for the optical drive. So I was thinking, perhaps that happened in your situation too?
m
0
l
!