Sign in with
Sign up | Sign in
Your question

Usb ports stopped working

Last response: in Storage
Share
August 11, 2012 7:18:24 PM

Hello, I'm having trouble where a couple of my USB ports have stopped working. I've tried a few things to get them working so right now I'm just trying to find out if it's a hardware or software problem. The laptop is an Acer 6930 running Vista home. 2 of the 3 USB ports have stopped working recently. Everything else seems to be working ok.

So far I've tried uninstalling them and restarting to let them reinstall again. When I uninstall from the device manager there are no errors and when reinstalling there are no errors. When I check properties it says all of the hubs are working properly.

I tried the updating drivers through windows and it says the drivers are up to date.

I also sometimes use virtual box where I connect USB devices through there, not sure if that could of caused things to get mixed up or a problem.

any other ideas? it is out of warranty so acer might not help me. if it comes down to it being a hardware problem, I guess my option is to get a USB hub for the 1 port that is working? there are no PCI slots, unless there is some other connecter that will convert to USB. if I have to go to the USB hub route would it be better to get one with a USB adapter to prevent overloading the last USB port? and would there be anyway to prevent the working USB port from having the same problem as the others?
a b G Storage
August 17, 2012 9:17:34 PM

Do you have both front & rear USB ports? Which one works? If the rears don't work but the front does it could be something wrong with BIOS or your usb ports may have gotten loose or broken from the motherboard somehow.
!