No Display

Today I decide to rework my wire management. After getting everything hooked back up my monitor has no picture. Im using a Sapphire 4850. Unfortunly I don't have another card to test. I did try a old moniter and no display on that either. the pc seems to boot up, card fan comes on but monitor just goes to power saving mode. Any ides would be much appreciated.
6 answers Last reply
More about display
  1. Well, since we know it was working before, I'd suggest triple checking all you connections or even taking it apart and reassembling it first, just to make sure everything is in place and snug.
  2. Thank you for your response. I brokedown the pc again and checked all connections still no joy. Im gonna let sit overnight. Any other troubleshooting steps anyone can suggestions?
  3. Do you have a motherboard/case speaker? Any beeps?
  4. Yes do have a motherboard speaker. Just have the initial beep to indicate startup. My motherboard: Asus M4A79XTD EVO. Have tried the HDMI, DVI and VGA outputs on the card no luck. Did find a old Ati 1300 card, tried that one no luck either. Which makes me think the motherboard has a issue but not getting any problem beeps at start-up.
  5. Bump
  6. Well, you probably have tried most of this stuff, but still worth a look, particularly near the bottom (but run through the who thing to be safe):

    http://www.tomshardware.co.uk/forum/261145-13-perform-steps-posting-boot-video-problems

    The other possibility is that the MB or something got statically damaged during the work.
Ask a new question

Read More

Radeon Monitors Graphics Displays