Sign in with
Sign up | Sign in
Your question

New Build's HD not recognized by Windows 7 during install, Help please

Tags:
  • Homebuilt
  • HD
  • Systems
Last response: in Systems
Share
June 19, 2010 7:13:33 AM

I've just put together my first PC as of yesterday, and everything worked fine until I got to the Win7 installation. At the point where I'm prompted to select a partition for installation, Win tells me there are no detectable disks, and then asks for drivers. I've been trying to troubleshoot by tinkering with the BIOS and swapping drives between the new homebuilt and an older Dell PC.

Here's the detailed symptoms:
1. HD not recognized during Windows Vista or Windows 7 install on both prebuilt and homebuilt PCs.
2. HD is detected by homebuilt's BIOS
3. HD is formattable and writable in prebuilt (but formatting didn't solve the problem)
4. Win7 install detects two drives that came from the prebuilt when placed in the homebuilt.
5. Using AHCI mode instead of native IDE didn't help
6. Win7 does not recognize 64 bit AHCI drivers provided by Gigabyte when pointed to them on disk and usb drive, but does detect the corresponding 32 bit drivers.

All three drives I toyed with were SATA so I'm guessing it's not that the necessary drivers are totally absent? (At least as far as the motherboard drivers go).

Any help would be much appreciated--thanks!

Processor: AMD Phenom II X6 1055T Thuban 2.8GHz
HD: SAMSUNG Spinpoint F3 HD103SJ 1TB 7200 RPM SATA
RAM: Mushkin Enhanced Blackline 4GB (2 x 2GB) 240-Pin DDR3 SDRAM Model 996781
MoBo: GIGABYTE GA-880GA-UD3H AM3
PSU: CORSAIR CMPSU-650TX 650W ATX12V / EPS12V
DVD: ASUS DRW-24B1ST/BLK/B/AS

More about : build recognized windows install

June 19, 2010 7:41:09 PM

Initially I was using the files from the CD specified by Gigabyte's manual (via USB Drive--drivers for Win7 found in/bootdrv folder of install CD). I've since tried out the drivers from their site that you linked to. Here's what happens when I try to use the drivers:

AMD SATA AHCI Driver
1. 64 bit drivers not found by Windows
2. 32 bit drivers detected but hidden due to incompatability with hardware

AMD SATA Raid Driver
1. 32 and 64 bit drivers detected but hidden

Gigabyte SATA2 AHCI/RAID Driver
1. Detects 8 copies of driver all incompatible.

Chipset/SATA Raid Driver Package
1. This package is confusing because it has multiple drivers included, and I'm not sure which are even applicable, especially since the manual never talks mentions anything about drivers for IDE mode.
2. Detected/Compatible Drivers: ATI SMBus Driver, but this is from a WinXP folder; and even if I try Win7 won't install it.
3. Detected/Incompatible: SB7xx AHCI RAID Controller and AMD RAID Console; SB8xx AMD AHCI RAID Controller
4. Not detected: SB7xx AHCI driver

Also, it can find the Vista AHCI drivers, but if I attempt to install any of the detected drivers I get an error that says I need to use 32-bit or signed 64-bit drivers.

I'm pretty clueless about how HDs are configured--should I be sticking with the default IDE mode or is AHCI better if I don't plan on setting up RAID arrays? Either way, it doesn't work at the moment with this new drive.

In IDE mode, how likely is it that this is a driver issue considering that Win7 recognizes two other totally different (but used) SATA drives?
m
0
l
June 20, 2010 2:09:39 AM

Managed to solve the issue myself after seeing that someone who also had a drive show up in BIOS but not in Win7 install.

Formatted the drive using gparted live bootable cd. Win7 recognized it in both Native IDE and AHCI afterwards.

Apparently formatting the drive via Disk Management on another Win7 PC just doesn't cut it.
m
0
l
!