Sign in with
Sign up | Sign in
Your question

Cannot Locate External Harddrive (Iomega ExtHD 1 TB)

Last response: in Storage
Share
August 13, 2012 5:50:02 PM

As the title says I can't find my Iomega Prestige harddrive anywhere on my Windows 7 Desktop =/. It is nowhere to be found under the Disk Management Utility. I have tried every port on the desktop, and it doesn't change anything. A USB Mass Storage Device appears under the device manager, but there's not much I can do, besides uninstall and reinstall it, which I tried, but to no avail. I guess at this point I will try to take it apart and see if it works without the casing, but I was wondering if there was an obvious solution which I'm missing. Cheers

- Adi
November 17, 2013 7:52:55 PM

Adi_39 said:
As the title says I can't find my Iomega Prestige harddrive anywhere on my Windows 7 Desktop =/. It is nowhere to be found under the Disk Management Utility. I have tried every port on the desktop, and it doesn't change anything. A USB Mass Storage Device appears under the device manager, but there's not much I can do, besides uninstall and reinstall it, which I tried, but to no avail. I guess at this point I will try to take it apart and see if it works without the casing, but I was wondering if there was an obvious solution which I'm missing. Cheers

- Adi


m
0
l
November 17, 2013 8:14:01 PM

I have a Win 7-64bit - i7, 24 gigs Ram, Zero Raid, I could only see that the Iomega was online, but it had no drive letter and I could not read it, in disk management I could right click and at one point I was only able to mark the partition as active. The option to change drive letter and path would not work no matter what I did. There were no other options there to help assign it a drive letter that worked. I even searched the Windows Help to no avail, until I did the following. I need to determine if the drive was still good.

So I then took the Iomega External 1TB hard drive and connected to a laptop using Windows Vista and bam, the laptop seen it, I can access all my files, but had to access as admin, so I learned my Iomega HD was still good.


So I reconnected it to my big machine Win7 - Home Premium i7 - 24gigs - Ram, Zero Raid. I went into Device Manager and I uninstalled the Iomega External HD at the Disk Drives location, make sure its at the Disk Drives and "not the Universal Serial Bus Controllers", and with out restarting the machine I used the "Scanned for Hardware Changes" and it located the Iomega and it brought it completely back online and assigned it a drive letter also. I had even tried uninstalling the drivers and that did no good until I uninstalled the Iomega at the "DEVICE MANAGER>DISK DRIVES. Prior to that it was only online and visible in disk management only, but not visible anywhere inside window period, it would not show in explorer/anywhere. Problem Solved!!! Now I'm watching a movie off of it #42 Jackie Robinson. GOOD LUCK!!
m
0
l
!