SSD wont boot in AHCI

I have a Kingston Hyperx 3K and AsRock Z77 Extreme 4 Mobo and when I was installing windows 7 for the first time I tried AHCI and I would get a very quick blue screen then the computer would reboot and it would continue this cycle until I powered down. I read to try booting it into IDE which fixed that problem and now windows is working however I was told AHCI is better than IDE for SSD. I have tried various methods (regedit for one) to be able to change the sata controller back to AHCI but everytime I have gotten the same message "BootMgmt missing"

Any ideas?
5 answers Last reply
More about wont boot ahci
  1. Did You change Bios to AHCI, then Do the reg edit. If so that is the reason.

    Must change registry, then reboot and change Bios.

    SEE: http://support.microsoft.com/kb/922976
    select eith "Fix it" or let me Fix it method
  2. Yup that was the first thing I tried. All the registry items except one were already set to 0. I only had to change one of them. Went to reboot and and change to ahci and it still said BOOtMgr missing.


    EDIT: It says BootMgr missing...not Boot Mgmt
    It then just says press ctrl alt del to restart and it continues this cycle until i change back to ide
  3. Is the firmware for the SSD the latest.
    also (probably more important) is Your Bios Up todate.
  4. whowhodilly said:
    Yup that was the first thing I tried. All the registry items except one were already set to 0. I only had to change one of them. Went to reboot and and change to ahci and it still said BOOtMgr missing.


    EDIT: It says BootMgr missing...not Boot Mgmt
    It then just says press ctrl alt del to restart and it continues this cycle until i change back to ide


    Anonymous said:
    Is the firmware for the SSD the latest.
    also (probably more important) is Your Bios Up todate.

    as far as i know there is no firmware update for my ssd yet and yes bios is up to date
  5. I had this problem for a long time even after trying every fix in this thread. Finally fixed it by turning of indexing in drive properties. Simple fix and still kicking myself for not thinking of it sooner.
Ask a new question

Read More

Hard Drives Storage