Sign in with
Sign up | Sign in
Your question

After Laptop HD upgrade, want to use old working drive as data drive

Last response: in Storage
Share
August 15, 2012 4:42:13 AM

Thinkpad T410 with SATA 2.5 drive. Upgraded drive to an SSD, got external 2.5 Sata enclosure to reuse old drive as a data drive. Cannot get any windows7 machine to recognize it. Show as not initialized and cannot initialize it because it gives me a Data Error (Cyclic Redundancy Check) error. I verified that the drive was good by putting it back into the laptop and throwing a win7 fresh build on it. All I want to do is take former laptop drives( that were boot drives) and re-format them and put them into external enclosures to use as external data drives. Many thanks for any help. I have tried several drive utilities, even booted Ubuntu which allowed me to format the drive and start clean ..with no luck.
August 15, 2012 5:05:45 AM

Now your problem could be one of two things, in descending order of likelihood: 1. your hard drive enclosure, or 2. your usb port. If you have another enclosure, a SATA - USB adapter, or even an external drive purchased as such, try those. If you purchased an external drive, swap the two, and try it. If that doesn't work, try all the USB ports on your computer. If that doesn't work, try it on another computer. Your idea is perfectly valid, I have formatted used laptop drives that were replaced by more capacitative drives. What model, exactly is the hard drive you're trying to use as an external drive?
m
0
l
August 15, 2012 5:43:32 AM

Thanks for the reply. This seems to be more of a process issue. I have 2 seagates, and a Hitachi, all of which..when plugged in...get lights, spin up and load of usb drivers and recognition of the drives. I have used a desktop and another laptop and the behavior is the same across all. Going into My computer, manage, disk management, ..they all show as un-initialized. Any attempts to initialize, give me the Data Error (Cyclic Redundancy Check) error. Whats crazy is I can take these drives, put them back into the thinkpad...boot the win7 usb key to start the rebuild..and I can format them and actually successfully load and boot..repeatedly win7. I remove the drive, try 3 different usb connections to use as a USB drive...and I get the same error. It seems like a format issue or something...any help appreciated.
m
0
l
Related resources
August 15, 2012 6:38:55 AM

Sounds like your hard drive doesn't like being replaced by an ssd. I'm sorry I can't be of much help. The only thing I can think of to recommend you to do is to go to My Computer -> right-click on the external drive-> Properties and look into things that look like could be of help with your problem. But, if these drives have jumper settings, you might need to change those. I.E., changing the jumper from Master to Slave. I hope this fixes it.
m
0
l
August 16, 2012 2:09:04 AM

Still have had no luck today. Tried killdisk and that was not able to wipe the disk. After some additional investigation I think I know the problem but still not the solution. This disk was on an IBM thinkpad, my previous one and it had a power-on and disk password. I had the same password for them. Knowing this, I took my new SSD drive out of the current laptop, put the old drive back in, booted into bios setup and disabled the passwords. While one of them went away, one password still comes up. Since I know it, I think it is giving me the access to the drive on that machine..and that machine only. I think...somehow this disk and it's password must be tied to the old cpu even though I can access after using the password on the newer thinkpad since I know it. Heck, I was even able tonight to get Ubuntu booted on the usb, use gpartd to remove and recreate a partition on the drive and even format it to Fat32!...thought I was good, took the drive out and hooked it to the usb external enclosure...connected it to another laptop and got the same inability to initialize. Since these are SATA drives there are no jumpers or anything. Think I might be hosed here. It is really frustrating that even knowing the password I may be out of luck in re-using these drives.
m
0
l
August 17, 2012 10:40:19 PM

UPDATE: SOLVED

Thanks to a fellow IBM'er friend who pointed me at this:

http://forums.lenovo.com/t5/T61-and-prior-T-series-Thin...

Bottom Line: Hard Disk password on thinkpads seems to be tied to the machine type. While I was able to take an old hd from an older T61 , put it into a T410 and boot it ( because I knew the password)..I could still not wipe/remove it. Luckily, I had a spare boxed refurb T60 that I keep here for emergency's for my team. I put the drive into it, booted to bios and was able to remove and wipe the password. This then allowed me to plug the drive into my external USB enclosure, connect it up to any of my computers, see it, initialize it and format it...Fantastic!

So beware, if you use HD passwords, you need to wipe them on the actual machine first before removing them. I sure wish all the fancy utilities that told me these drives were bad would have been smart enough to tell me it was the HD password.

Thanks for everyone's help!
m
0
l
!