Sign in with
Sign up | Sign in
Your question

5770 - Win7 won't load

Last response: in Graphics & Displays
Share
Anonymous
a b \ Driver
May 14, 2010 10:48:13 PM

System specs:

MB - GIGABYTE GA-790XTA-UD4 R
VGA - ASUS EAH5770 CUCORE/2DI/1GD5
PSU - OCZ|OCZ700MXSP 700W RT
CPU - AMD|PH II X4 965 3.4G 6M RT
MEM - 2Gx2|OCZ OCZ3BE1600C8LV4GK R
HD -1T|SAMSUNG HD103SJ 32M 7K

I recently built a new system and so far all of the components are running fine but I'm having some serious problems with Windows 7 drivers and my radeon 5770. Whenever I try to boot up Win7 normally, the screen goes grey/black for a bit, then displays a generic win7 background with no icons or keyboard/mouse functionality (it just hangs there).

If I go into safemode, I can remove the ATI CCC drivers and reboot, and it will load win7 normally, but it automatically updates the 5770 drivers again and if I restart I'm back to the same freezing problem. Also, my maximum resolution after uninstalling the drivers is 1440x900, but my monitor is 1080p native. I've tried the newest drivers on ATI's site and when they didn't work right I also tried drivers off the CD. Both resulted in the same problem.

Has anyone else encountered this problem or know a fix?

More about : 5770 win7 load

Anonymous
a b \ Driver
May 15, 2010 12:40:37 AM

I am using driversweeper any time I uninstall the drivers. I've got some 8.67 drivers that are supposedly working, but catalyst control center won't install properly and I can't change screen resolutions or activate a 2nd monitor. I've never had problems with a graphics card like this before, this is very frustrating.
m
0
l
!