Catalyst drivers 10.3 not allowing CrossfireX

I got an additional 4850 today, and I'm sure that the card works. But the drivers don't have an option to enable CrossfireX, so I looked it up and it seems that ATI is aware of this problem and you have to switch back down to 10.2 Catalyst drivers. The problem with this, is I can't seem to find a reliable source that provides these drivers. Is there a fix to this issue without maybe having to get 10.2 drivers?
4 answers Last reply
More about catalyst drivers allowing crossfirex
  1. get 10.4 driver and if that don't work, the look around in the BIOS and see if thats the problem. Have you tried both cards separately? What PSU have you got??
  2. Yeah I have tried both cards separately and they both seem to work. I have a 650 Watt Corsair PSU, I'll try to find the link for newegg. It's 85 plus if I remember correctly.

    What should I be looking at in the bios to see if there is an issue for multiple GPU's? first time CrossfireX user so I don't know exactly what to look for. I know there is a program that will be able to see if both GPU's are being recognized but I'm not sure what it's called
  3. Edit: this is the link to my power supply

    http://www.newegg.com/Product/Product.aspx?Item=N82E16817139005

    I have 8GB of RAM (4 sticks)
    AMD Phenom II X3 720
    One HDD
    One DVD drive
    and Two 512 MB HD 4850's. This should power it, correct?
  4. Bump

    Is my PSU fully capable of handling that load?
Ask a new question

Read More

Radeon Drivers Catalyst Graphics Product