Sign in with
Sign up | Sign in
Your question
Solved

Raid1

Last response: in Storage
Share
August 16, 2012 5:27:17 AM

I've been running raid1 for a while now on 2 1tb hard drives. Wanted to expand for memory issues so I picked up 1 3TB Seagate hard drive that I wanted to boot from, leaving the other 2 1tb hard drives mirroring one another for safe data storage.

After installing win7 on the 3tb hard drive, I turned on Raid and the OS failed to boot.

What would be the best course of action to get this to work? I am thinking that there is a support issue with the 3tb hard drive and that for whatever reason it is messing things up. Going to return it tomorrow in exchange for a 1 tb...


Thank you for any advice!

More about : raid1

a c 311 G Storage
August 16, 2012 11:37:29 AM

Are we to understand that you are able to boot Windows 7 from your 3TB HDD as long as the RAID 1 pair are disconnected?
m
0
l
a c 379 G Storage
August 16, 2012 12:08:30 PM

Were you previously booting from the array? If you were and now you are trying to boot from the 3TB, you may need to go into the raid bios and make the array non-bootable.

Also, is this the 32 bit or 64 bit windows 7? Only the 64 bit can boot from a GPT disk and even then, it requires a EUFI motherboard.

Q. Can Windows 7, Windows Vista, and Windows Server 2008 read, write, and boot from GPT disks?

A. Yes, all versions can use GPT partitioned disks for data. Booting is only supported for 64-bit editions on UEFI-based systems.


http://msdn.microsoft.com/en-us/library/windows/hardwar...
m
0
l
Related resources
August 16, 2012 1:55:38 PM

Sounds like your motherboard defaulted the RAID 1 configuration as your default boot device and removed your OS Hard Drive from the boot list. Take a look at the bios boot options.
m
0
l
August 16, 2012 2:42:31 PM

First off, THANK YOU for the fast replies to this! I have a business meeting this afternoon and have to get some stuff rendered so I'm pulling out my hair a little bit.

I would also like to start by sharing my specs

64 bit system running Win7 Professional
Asus p8z68 Deluxe motherboard
Intel Ivy Bridge 3770k (had to flash bios to make the MB compatible with 3rd gen i7)
Seagate Barracuda 3tb drive
2 1tb drives
------------------
@fzabkar- YES, that is correct. Originally when I had raid enabled I (without any OS installed) and had the 2 1tb drives paired, for some reason the computer was only read 764 gigs of the 3tb drive.. When raid wasn't enabled the computer was reading the whole thing (2tb partition and the rest in it's separate partition). So I disabled raid, installed windows on the main 2tb chunk, then when I had it going again, I enabled raid (and figured it would boot up now after the 3tb was partitioned for win7....not)

@DarkOutLaw and Hawkeye22- I will be sure to double check the boot options. One thing that is sort of funky is that I think my cmos battery took a ***, because when I was setting this all up in the bios the raid was turned off when it should of been turned on! (Plus i was reading a C drive and a F drive with almost the same stuff on it back when I just had the 2 1tb installed... should of only seen one drive there if raid1 were initialized)..


Thank you for any and all help. If you want bios screen shots I'll take some with my camera and post them up on the forum.. I will check my boot options in the bios and raid menu... I might even write down my OC settings and restore the bios to factory default to see if that does anything.

m
0
l
August 16, 2012 2:45:39 PM

and another thing... Just to make 100%, there is no chance that the hard drive is just too large and is cause problems because of size? I've never owned anything past a 1tb hard drive so this is new ground for me.
m
0
l

Best solution

a c 379 G Storage
August 16, 2012 6:15:56 PM

The bootable option in raid may be a non issue. I don't know for sure because I never tried having another bootable drive in the system when I was using a bootable raid. If you can't highlight the option for bootable and changing it to no, then I assume that this option is a one time setup when you originally created the raid volume.

The boot device in the bios may override the raid bootable setting, but can't say with 100% certainty.

As for your drive not seeing the full size of the 3TB drive, it sounds like you partitioned the drive using MBR instead of GPT. Drives over 2TB must use GPT to see anything over 2TB. In order for a GPT partitioned drive to be bootable, you need a 64 bit OS, which you have, and a EUFI motherboard, which your's seems to be. So, if you didn't create the partition as GPT, you will need to recreate that partition.
Share
August 16, 2012 8:33:30 PM

Thanks for all the help guys! Today I returned the 3tb hard drive in exchange for a 1tb hard drive... Everything seems to be (I don't want to speak too soon) working alright and registering.

And yes, Hawkeye, you are correct, to get the full 3tb on one partition it would have to be GPT. I just assumed save myself the headache, haha, plus I don't need 3tb on my main if I have one tb (2tb mirrored) to store all my data.

If I run into any more issues with this, I'll reply on this thread, but I appreciate everyones help! Didn't have any work to present at the meeting today, so I just made some stuff up, haha.
m
0
l
August 16, 2012 10:01:12 PM

So, I everything seems to be working alright now...

Here was one main issue (I could of probably got the 3tb hd working if I would of tried this, but I didn't want to dink around with the GPT thing)... I had to update Intel's Rapid Storage technology on the installation of Windows...

I guess they changed some stuff around in newer hard drives.. For anyone in the future looking for help with this issue, follow this thread on Toms "where I got this solution"

All seems to be working now. Thanks again everyone and below is the thread.

http://www.tomshardware.com/forum/34174-63-recovery-err...
m
0
l
August 26, 2012 11:57:02 PM

Best answer selected by 9krausec.
m
0
l
!