Sign in with
Sign up | Sign in
Your question
Closed

HALP! Samsung 830 ssd won't play with Intel Rapid Storage (IRST)

Last response: in Storage
Share
August 16, 2012 4:16:47 PM

Hi All!

OK, I'm not exactly a n00b, I've fixed Computers for over 32 years, but this one's got me stumped.

My system is in my Profile, but I'll put it here for reference ...

Gigabyte GA-Z77X-UD5H
2X Western Digital Raptor 10K RPM 300GB RAID 1 (Boot)
5X WD 750 GB in RAID 6 (DATA) on HighPoint RocketRaid 4320
128GB Samsung 830 SSD (IRST Cache of Boot) <--- I HOPE!
16 GB GSkill Ripsaws X 1600 XMS OC'd
I7-3770S with CM Hyper212 EVO
XFX Radeon HD 6870 (Dual Fan)
Thermaltake: Element G Case & Smart 850W PS
Win 7 Ultimate x64

Just spent almost 3 weeks rebuilding it after I made the mistake of upgrading to a Seasonic PLATINUM-1000 ATX 1000 Power Supply on my old Asrock Z68 Extreme 4 Gen3 i52500K system. New P/S ran fine for 15 mins then ~~BANG~~ (literally - made my wife jump in the next room!). Blew my Mbd, CPU, Blu-Ray/DVD Drive, & Video Card.
Long, very sad story. Good luck to me being reimbursed.

Now to my problem - I've D/L'd all the latest drivers, BIOS, Firmware, etc. but I can't seem to get my new Samsung 830 to act as a Cache using Intel's Rapid Storage Technology.
If I boot, Samsung Magician sees the Drive. Intel RST App sees the drive. Windows Disk Mgmnt sees the drive. RST shows two Raptors running RAID 1, they show fine. The SSD shows fine. There IS an accelerate button. When I hit it it pops up the accelerate options. The SSD is shown, but if I start it, NO MATTER WHAT COMBINATION OF SETTINGS I try - it goes out, thinks for about 30 secs and comes back with an "Unknown Error had occurred" message. At this point the drive had vanished from everywhere, and Device Mangler {Ahem} ;-) says there's an Unknown device. Deleting & rescanning won't fix, nor will reloading drivers (says there aren't any matching drivers). A full reboot fixes it and there's the drive again.

Now, mind you, I can partition and create a drive normally, I just can't get the damn Rapid Storage to use it as a accelerator for my RAID 1 !!
I have the SSD on Port 0 (6GBs) and the RAID on Ports 2 & 3 (3GBs). I originally had it Port 0 & 1 RAID Port 5 SSD, but realized my drives are 3GB max and the SSD is 6GB, the Z77 chipset is set for Ports 0 & 1 for 6GBs, Ports 2-5 3GBs, so I moved them. No change to problem, but if I get it working that will be the fastest setup.

Best I've come up with is two pieces of ~maybe~ info:
1. Samsung CLEARLY wants their drive to be hooked to an AHCI port, and of course, it's hooked up RAID. But note - the Owners manual says Pg7 "... that the operation mode is set to either [AHCI] or [RAID] ...".
2. Pg 9 shows (Warranty info) "not used for intended function ... used in an enterprise server system, workstation, PC cache memory, or storage system." WHAAAT? You violate the Warranty if you use it as CACHE? Huh? I think their referring to use in a Enterprise server environment, not in a home PC with a RAID. If not, they need to rethink that.

Needless to say I scoured the INet for answers, and understand Samsung makes a fine drive but their Tech support is abysmal, no tracking of contacts, each Tech starts new, after 3 weeks of hell rebuilding this thing I'm NOT up to that. So I came to the place that has always answered the tough questions.

Anybody wanna take a stab at this? Oh - The idea of using the SSD as a boot drive is out - WAY too small, and after all of the purchases above, my wife will KILL me if I hit her up for a bigger one LOL! I like my body parts in their current arrangement, thank you. Not perfect, but they work.
I'd love to resolve this, I'd hate to have to return it, my system is really I/O bound and I can't afford to go SSD on boot at this point.

Thanks SOOO much in advance,
Bob M. aka PuterPro (although this one makes me feel like PuterN00b!)
August 16, 2012 5:56:19 PM

OK Folks, I WON!

After screwing around for hours on this I UNinstalled Intel Rapid Storage 11.5 with Revo uninstaller to get all of it (saying no to uninstalling drivers).

Then I installed 11.2 (which didn't work either), then installed 11.5 from Gigabyte's Website OVER the 11.2.

Two reboots later and TA-DA it worked.

11.5 has an additional option for how much to put in cache:

1. 18.2 (?) GB
2. ALL of the hard drive (64GB)
3. CUSTOM (new). I chose Custom, 64GB and BAM, 10 secs and we were done. I did that just in case so I could partition the rest.

I then went to Disk Management & created a NTFS partition for the rest of the space, I'll put my most used Programs there.

Hope this helps some other poor chap (or Gal)!

All the Best, PuterPro
Score
0
a c 283 G Storage
August 16, 2012 8:30:12 PM

The general rule of thumb is that using an SSD as a cache for a RAID array can result in an unstable system. The instability can happen immediately or it can happen days or weeks later. It is a crapshoot!
Score
0
Related resources
August 19, 2012 1:55:35 PM

@JohnnyLucky - Thanks for your input, but that's:

1. An extremely broad statement.
2. Doesn't give me ANY info at all, just an opinion. Granted, I don't know you and you may be the biggest Super Tech that walks the earth, but this strikes me as a Trolling comment. Haven't got time for that. I don't frequent the Forums (despite having MANY Technical interests) as I haven't the time. Wish I did since I have been at this a long time and could solve or give input to a heck of a lot of the Q's posted here. Would love to contribute more, but as it is, I haven't the time.
3. Assumes {AHEM} that Intel created a technology that just doesn't work. I seriously doubt that. They do stumble sometimes, all software has it's hazards, but Intel's got a pretty good track record. Besides, I'm fanatical about backup, and handle my OS, Programs, and Data separately.

If you have any concrete evidence, or links to SCHOLARLY articles from REPUTABLE sources, fine, give 'em up and my apologizes, but without actual INFO, I'm considering it as a troll message.


All the best, PuterPro
Score
0

Best solution

a c 184 G Storage
August 19, 2012 2:13:16 PM

This topic has been closed by Area51reopened
Share
August 19, 2012 2:17:23 PM

Best answer selected by PuterPro.
Score
0
!