Sign in with
Sign up | Sign in
Your question

Low Frame Rate on "Hot Computer"

Last response: in Graphics & Displays
Share
May 16, 2010 12:23:52 AM

Hi,

Using Gigabyte X58A-UD5 with two ATI 5770 Graphics cards crossfire. CPU is an i7 930 2.8 GHz.
12 GB of DDR3 memory.

Driver Packaging Version 8.671-091104a-091528C-ATI
Catalyst™ Version 09.11
Catalyst™ Control Center Version 2009.1104.959.17837

Also using Windows 7 Ultimate 64 bit version.

I ran a few graphics tests, one was ATITool and the frame rate is over 1000 FPS, Wow! I was ready for great games.
On my other older Pentium D 830 the frame rate is 115 FPS.

The old computer has no problem making over 40 FPS with FlightSim 2004 and naturally not great with FSX. Now for the problem. The Hot new computer using FS2004 has lower frame rates than the old computer and acts like my old X-300 graphics card did in the old computer before the X-800GTO was installed. The graphics are also horrible looking unless the settings on Catalyst Control Center are all set to near maximum quality. This obviously slows everything even more. The old computer settings on Catalyst Version 2008 are set to the middle range and look great. Almost no Aliasing visible.

The new computer runs all other applications like nothing I've ever seen. It is wonderful. Running benchmark tests it is amazing. So I am at a loss about the slow graphics on FS2004.

Any ideas at all would be greatly appreciated. My location is on Maui so computer help is very limited.

a c 189 U Graphics card
May 16, 2010 1:57:18 AM

What about the other games? Does it slow as well?
What about your PSU? brand? model?
Have you tried install the latest driver (10.4 instead of 8.6)?
May 16, 2010 9:06:57 PM

Not yet, just got back from some work. I'm going to try other drivers. I hope they will work. I have had problems with ATI in the past. Thanks for the suggestion!
!