Sign in with
Sign up | Sign in
Your question

Problems running games?

Last response: in Systems
Share
Anonymous
a b B Homebuilt system
June 22, 2010 10:58:06 PM

Hi all,

I built this system about a year ago and I have had this problem since the beginning. I have a ATI Radeon HD 4850 by MSI I don't think they make it anymore, all I know is that it had a special heatsink. It was an open box product bought from Newegg, and I can't find it there anymore either. It works well and doesn't heat up too bad (I can't tell you idle/load temps). I'm running windows Vista 64 (OEM for sys. builders), 8GB of RAM, 1TB of memory (2x500 GB).
I have a problem running all kinds of games:
-Tropico 3
-Cities XL
-Fallout 3
-Section 8

and a couple others that are just freeware

My question is, Why won't these games work? Is it my video card? Is it a DirectX issue? Is it Windows Vista?

and Thanks ahead of time.

More about : problems running games

Anonymous
a b B Homebuilt system
June 22, 2010 11:27:18 PM

I figured out that I have the MSI 4870R 1GB version, not a 4850.
June 23, 2010 1:34:05 AM

its more likely vista throwin sticks in ur game rather than a video card...ur card should play those games.

You must describe to us what the actual problem is...do the games just not start? Have you tried to start them?

just in case you would like to tell us the idle/load temperatures feel free to download the following software.

prime 95
occt

http://www.ocbase.com/perestroika_en/index.php?Download

*don't do that until you specify how the games are not working exactly*
Anonymous
a b B Homebuilt system
June 23, 2010 3:01:32 AM

Quote:
its more likely vista throwin sticks in ur game rather than a video card...ur card should play those games.

You must describe to us what the actual problem is...do the games just not start? Have you tried to start them?

just in case you would like to tell us the idle/load temperatures feel free to download the following software.

prime 95
occt

http://www.ocbase.com/perestroika_ [...] p?Download

*don't do that until you specify how the games are not working exactly*


The games all launch perfectly, but after I start playing for about 5 minutes the screen does one of two things:
-Goes black
-Or goes gray

I don't know the significance of that

also, I used CCC (Catalyst Control Center) to turn my GPU's fan to 100%, also I used the software you recommended and my idle temp is 55C and my load temp is (I don't know if this is right, but) 106C. Not unless I read the graph wrong.
!