Sign in with
Sign up | Sign in
Your question

Pentium 4 system no display after processor change

Tags:
Last response: in CPUs
Share
August 21, 2010 5:00:09 PM

Yes i know, its an old system before anyone starts and probably least of your priorities, however if i successfully resurrect this computer after my calamity which killed it i will gain permission to build my dream new i7 system...
so please help...

The cause,
Basically myself... I was a bit naive at the time of the problem and didn't take ESD seriously and went in unprotected to clean the heatsink/fan on the family pc. I believe i may have fried the proccessor as i took it out very carelessly and touched it without full ESD protection.
The problem,
after my poor error i have read into ESD protection methods much more and fully understand how to handle each component and the system overall to prevent ESD damages, from this i ordered a new pentium 4 (478 socket) to install and therefore set my affairs straight again. However after replacing the processor the same problem occurs as before i changed it. This problem is that there is no sign of display. I will give you now as much detail as possible from when i hit the on button but please ask questions if there is anything essential i have not included.
After pressing the on button, the fans begin to spin as per usual and it would seem no problem is present from looking inside the case. the HDD light turns on and everything is fine. however after a short period (5-10 seconds) the HDD light turns out and does not reappear, after this time (including time from initial start up) there is still no display. Because of this i have ran through the guidelines set to follow in such a problem on this site and unfortunately no success has been found.
I did discover something that i believe may help in discovering the source of the problem. In the guide it states that if the system is stripped down to its core components (PSU, CPU and MOBO) when the power is turned on there will be a beep issued from the onboard speaker indicating a memory error (due to no memory being present). However no such beep is sounded from my system, which i believe indicates an error in PSU MOBO or CPU, i have changed the CPU so that can be eliminated, but i don't understand how the other two can be the problem.
Please help me get this system back working, i really don't understand what is causing the problem, please don't hesitate to ask further questions you feel may help concluding this.
Thankyou for your time, here are the system's spec if it helps...

MOBO: P4R800-VM
CPU: Pentium 4 3.00 Ghz 478 socket
GPU: nvidia GFX5500 (inno3D)
RAM: 2GB DDR1 (too much for the system, but i've tried mixing and matching 4 units of various size with no changes, and it worked before fine with all installed)
August 22, 2010 1:02:44 PM

Anyone...?
a b à CPUs
August 22, 2010 3:55:56 PM

Does your bios show up?
If your not even getting a post screen then it is serious.
Visually inspect all the capacitors on the mobo.
computers built around 2002-2004 especially OEM's had problems with a bad batch of caps.
Look at each one and if it is split at the top and has a crusty yellow substance coming out of it then the caps are bad.
Also does the mobo have onboard graphics or do you have another graphics card you can try?
If you have onboard video try using that.
Let me know if how it works out.
Related resources
August 22, 2010 4:59:14 PM

No, unfortunately theres no bios show at all, i can't see anything significantly changed on the motherboard and i've looked quite hard for anything indicating its broken, but no visual evidence nor any scent of burning from anywhere. (i thought it was worth trying?)
yeah it does have onboard video, but its been run for its life so far with a video card in the AGP port. However i've tried both and still nothing. :/ 
How serious are we talking?.. i've got a feeling its most likely to be the mobo, what do you think?
a b à CPUs
August 22, 2010 5:16:46 PM

I hate to say mobo first without knowing for sure.
Use a flash light and visually inspect every capacitor.
Google capacitor if your not sure what your looking at.
If you see split crusty yellow caps then your mobo is dead.
Did you try a different monitor?
August 25, 2010 9:12:44 AM

Okay i've looked intesnsely at each and every one of the capacitors now and they look as good as new :/ 
And yeah i've tried another monitor and still the same :/ 
!