Sign in with
Sign up | Sign in
Your question

Low fps, on high and low settings. No difference.

Last response: in Graphics & Displays
Share
May 18, 2010 4:47:33 PM

Hello there.

First of, I want to say that I am a total newbie. So please bare with me.

I week ago I just bought my new computer with the following specs:

AMD PHENOM II 965 x4 (4x3.4ghz)
GIGABYTE 790XT-USB3
HD5850 1GB DDR5
100GB HDD, 7200RPM (32MB CACHE) (WD)
4GB DDR3 1333MHZ KINGSTON RAM "DUAL CHANNEL"
700W Cougar, 80plus, SLI & XFIRE

I'm pretty sure that I should be able to play Battlefield Bad Company 2 quite good, but I seem to experience a fps on average 35-45 fps on all settings. From low to high. It doesn't improve fps even though I set everything to minimum. Odd.

Here is how it looks in 3DMark Vantage on performance settings:


I have the new ATI driver 10.4 catalyst installed, and I got no idea whatsoever what the problem might be. It is really tearing me appart that I'm not able to play any games and actually enjoy em' due to the lag and slowmotion feel.

Sincerely
Mokka



a c 236 U Graphics card
May 18, 2010 6:25:41 PM

what is your monitor's native resolution?

35-45FPS on BBC2 high settings is very good, its one of the most hardware demanding games.
a b U Graphics card
May 18, 2010 6:44:08 PM

Try downgrading the driver catalyst to 10.1, 10.2, 10.3.
That indeed is odd, but it's a known issue, googleing shows a lot of the same cases.
Related resources
May 18, 2010 7:05:31 PM

It's 1920x1080.

Same as in ingame.

Well, I guess it is, but people with the same hardware as myself get a lot better performances. Just look at the score on 3DMark Vantage + as I said doesn't resolution and other settings matter. The fps is stuck on average 35 with low setup and with high.
May 18, 2010 7:37:21 PM

kiban said:
Try downgrading the driver catalyst to 10.1, 10.2, 10.3.
That indeed is odd, but it's a known issue, googleing shows a lot of the same cases.


I've just downgraded the driver to 10.3b. and it def. improved the visuals.

My fps in high went down to 20 fps :-(, but I managed to get80 fps on the lowest setup.

I still don't think my gear justifies 20 fps with a setup on high, as I've seen people with same gear as me get around 50 fps? :cry: 
a b U Graphics card
May 18, 2010 8:01:15 PM

Download Stalker clear sky benchmark tool http://files.gsc-game.com/st/bench/stkcs-bench-setup.ex...

And run it at 1920x1080 ultra setting and enhac full dynamic light DX10, in advanced check DX 10.1 without antialiasing and post a screenshot of the results if you please.
The bench take 9 minutes or so..and the download speed of the bench can be slow, it's from the official website and it's known to have bad conection :S
May 18, 2010 8:10:45 PM

kiban said:
Download Stalker clear sky benchmark tool http://files.gsc-game.com/st/bench/stkcs-bench-setup.ex...

And run it at 1920x1080 ultra setting and enhac full dynamic light DX10, in advanced check DX 10.1 without antialiasing and post a screenshot of the results if you please.
The bench take 9 minutes or so..and the download speed of the bench can be slow, it's from the official website and it's known to have bad conection :S


Takes some time to download, but I will post a screenshot of the result when done. Thanks for the help mate!
a b U Graphics card
May 18, 2010 8:54:38 PM

Np, take your time.
a b U Graphics card
May 18, 2010 9:33:12 PM

Keep in mind, the ATI 5850 may be running Bad Company 2 with DX11 mode, which means lesser FPS but a higher over all image quality. You can try forcing the game to run in DX10 mode.

I game with an SLI GTX 260 setup on DX10 @ 1920x1080 and can see 50-60FPS as an average in BC2.
May 18, 2010 9:37:35 PM

jerreece said:
Keep in mind, the ATI 5850 may be running Bad Company 2 with DX11 mode, which means lesser FPS but a higher over all image quality. You can try forcing the game to run in DX10 mode.

I game with an SLI GTX 260 setup on DX10 @ 1920x1080 and can see 50-60FPS as an average in BC2.


How do I force my game to run with DX10 ? I'm also getting cheap fps in Assasins Creed 2. Average 27. Is it also running in DX11 ?

Note: By the way - I just ran a 3DMark Vantage - and got.. hang on 7581 in score. That can't be right?
a b U Graphics card
May 18, 2010 9:59:27 PM

Assasins creed 2 is Xbox360 ported game, and it has a lot of issues, such as shadow flickering low fps even with lowest settings and more, the optimization sucks... also, unlike assasins creed 1, the second game is only DX9.
Either way, at BC2 demo, my fps are 60 stable with vsync enabled, and from time to time it gets down a little, running on HD 5870.

On the other hand, when you show us the benchmark screenshot, I will be able to see if your card is in fact faulty or not.
May 18, 2010 10:01:45 PM

kiban said:
Assasins creed 2 is Xbox360 ported game, and it has a lot of issues, such as shadow flickering low fps even with lowest settings and more, the optimization sucks... also, unlike assasins creed 1, the second game is only DX9.
Either way, at BC2 demo, my fps are 60 stable with vsync enabled, and from time to time it gets down a little, running on HD 5870.

On the other hand, when you show us the benchmark screenshot, I will be able to see if your card is in fact faulty or not.


Oh. Thanks. That makes sense then.
I'll upload the screenshot tomorrow. What an aweful slow downloading speed :ouch: 
:D 
a b U Graphics card
May 18, 2010 10:04:29 PM

MokkaLokka said:
How do I force my game to run with DX10 ? I'm also getting cheap fps in Assasins Creed 2. Average 27. Is it also running in DX11 ?

Note: By the way - I just ran a 3DMark Vantage - and got.. hang on 7581 in score. That can't be right?


I'm personally don't have BF2 but i do have assassin's creed and my gtx 275 get get like to 60fps so i can enable vsync. And no assassins creed 2 only has dx 9. I'm wondering if your card is getting stuck in 2d mode, download gpu-z, then go to the sensor tap, then click on the log to file box, start up a game, when you get ingame you can exit out, check the text file and see if your gpu reached it's normal clocks
a b U Graphics card
May 18, 2010 10:05:31 PM

Yeah..., I tried to get another link, but couldn't find a mirror.... every website pointed to the official download site :p 
May 18, 2010 10:59:38 PM

What make and model is your power supply?
May 19, 2010 7:30:05 AM

hellraiser06 said:
What make and model is your power supply?


Erhm' I'm not quite sure if this is what you ask for: 700W Cougar, 80plus, SLI & XFIRE?
a b U Graphics card
May 19, 2010 11:55:43 AM

Known problem in BC2 as of the latest patch. Don't know any fixes yet...
May 19, 2010 3:18:42 PM

gamerk316 said:
Known problem in BC2 as of the latest patch. Don't know any fixes yet...


I haven't updated and still have the basic version. If you read the whole post this is not only for BC2, but also for other games as Settlers 7. Thanks anyway :-)
May 19, 2010 3:23:54 PM

kiban said:
Yeah..., I tried to get another link, but couldn't find a mirror.... every website pointed to the official download site :p 


I ran the Cleasky Benchmark on 1920x1080 ultra with dx10 and this is what I got:



May 19, 2010 3:31:44 PM

jonnyboyC said:
I'm personally don't have BF2 but i do have assassin's creed and my gtx 275 get get like to 60fps so i can enable vsync. And no assassins creed 2 only has dx 9. I'm wondering if your card is getting stuck in 2d mode, download gpu-z, then go to the sensor tap, then click on the log to file box, start up a game, when you get ingame you can exit out, check the text file and see if your gpu reached it's normal clocks


What is my normal clocks?

This is what I get:



edit:
is the default clock supposed to be 400MHz ?




a b U Graphics card
May 19, 2010 4:00:43 PM

Well when your in desktop mode, your gpu will cycle down to a lower power state to save power and reduce heat, idle or desktop which is the lowest, for just surfing the web word documents, theres a 2d mode for video playback, i forget the exact clocks, i have an nvidia card, but it should cycle up 725 mhz which in your first screen shot it looks like you are, Still just to make sure it's reeving up in games to eliminate that possibility,

click on the sensor tap, and on the bottom left click the log to file box. It will as for a place to put the file, just put it anywhere you can find it easily. Start up BF 2 wait till your in game for 2 or 3 minutes, then exit out. Check the log file if any of them say 725 mhz core 1000mhz then that's not the problem
a b U Graphics card
May 19, 2010 4:07:10 PM

As JonnyboyC said, check the clocks of the card( run GPU-Z then start a game, play a little, and then close and check the average clock speeds)


Well, this are the results of hd 5850 a random guy that benchmarked a lot of games:

http://i37.tinypic.com/25ukswg.jpg (As it says in the website, no AA was used for the test)
The website : http://www.xtremesystems.org/forums/showthread.php?t=23...

My test results with hd 5870:

http://img94.imageshack.us/img94/4944/nonclocked.png


Keep in mind, that stalker clear sky benchmark day night and rain varies a lot, but the one that doesn't is SUN RAY's.

Your card seems to be under performing, and I recommend speaking with XFX(is that the ensambler right?) and ask for support, also start thinking about RMAing the card.
May 19, 2010 4:19:48 PM

jonnyboyC said:
Well when your in desktop mode, your gpu will cycle down to a lower power state to save power and reduce heat, idle or desktop which is the lowest, for just surfing the web word documents, theres a 2d mode for video playback, i forget the exact clocks, i have an nvidia card, but it should cycle up 725 mhz which in your first screen shot it looks like you are, Still just to make sure it's reeving up in games to eliminate that possibility,

click on the sensor tap, and on the bottom left click the log to file box. It will as for a place to put the file, just put it anywhere you can find it easily. Start up BF 2 wait till your in game for 2 or 3 minutes, then exit out. Check the log file if any of them say 725 mhz core 1000mhz then that's not the problem


GPU Core Clock , GPU Memory Clock GPU Temp Fan Speed , GPU Load Fan Speed , GPU Temp #1, GPU Temp. #2 ,
725.0 , 1000.0 , 54.0 , 24% , 100% , 0 , 53.5 , 53.5 ,

This is how it performs ingame.

.. by the way. Why is my cards clock set to 400 MHz as default? I've seen others set to 750 MHz
May 19, 2010 4:21:57 PM

kiban said:
As JonnyboyC said, check the clocks of the card( run GPU-Z then start a game, play a little, and then close and check the average clock speeds)


Well, this are the results of hd 5850 a random guy that benchmarked a lot of games:

http://i37.tinypic.com/25ukswg.jpg (As it says in the website, no AA was used for the test)
The website : http://www.xtremesystems.org/forums/showthread.php?t=23...

My test results with hd 5870:

http://img94.imageshack.us/img94/4944/nonclocked.png


Keep in mind, that stalker clear sky benchmark day night and rain varies a lot, but the one that doesn't is SUN RAY's.

Your card seems to be under performing, and I recommend speaking with XFX(is that the ensambler right?) and ask for support, also start thinking about RMAing the card.


XFX is the ensamler yeah. So RMA (I guess that means to turn it back?) should be done via. the shop where I purchased the computer?
Sigh, how troublesome.
a b U Graphics card
May 19, 2010 4:25:20 PM

Yes, you need to contact the shop where you bought the card, and go from that.
I never had to RMA anything so I can't give you advice on how to do it, hopefully someone can and will.
May 19, 2010 4:30:56 PM

kiban said:
Yes, you need to contact the shop where you bought the card, and go from that.
I never had to RMA anything so I can't give you advice on how to do it, hopefully someone can and will.


So this is an error that can't be fixed digitally?

I've just contacted the shop where I purchased the computer and hopefully that'll solve my problem. I'll keep the topic running until the matter is solved. Thanks for the help, a lot!
a b U Graphics card
May 19, 2010 4:38:20 PM

Digitally could be, that's why I suggested speaking with XFX, maybe a bios review can fix the issue, who knows. Try XFX website, on "support" and "contact us" (probably you need to register first) and expose your problem to them.
May 19, 2010 5:38:41 PM

Guys, I think the real culprit here is the power supply. Maybe its not able to supply enough power when required. Cougar is not a known brand anyways, right?

OP, do you have access to another power supply, preferably from Seasonic, corsair, PCP&C, coolermaster etc..?
May 19, 2010 5:47:12 PM

hellraiser06 said:
Guys, I think the real culprit here is the power supply. Maybe its not able to supply enough power when required. Cougar is not a known brand anyways, right?

OP, do you have access to another power supply, preferably from Seasonic, corsair, PCP&C, coolermaster etc..?


Unfortunately I do not have other PSU's. I got Cougar recommended by another hardware-guy. Why should the shop where I bought it accept the upgrade if it didn't work properly with the gfx? .. but what do I know :lol: 
a b U Graphics card
May 19, 2010 7:09:21 PM

European brand doesn't mean not known brand.. much discussion has been about that already IE be quiet etc....

If the card isn't getting enough juice, gaming would crash, and/or pc won't boot, but it's worth trying, you can always try the graphic card on another computer too...
May 28, 2010 7:18:53 PM

kiban said:
European brand doesn't mean not known brand.. much discussion has been about that already IE be quiet etc....

If the card isn't getting enough juice, gaming would crash, and/or pc won't boot, but it's worth trying, you can always try the graphic card on another computer too...


So I've got a new card, and I am now scoring 46 fps in the Stalker Benchmark. Is there any way to optimize this? I run games a lot better, but still not optimal.
!