Sign in with
Sign up | Sign in
Your question

[Solved] Windows 7 64-bit only finds 1/2 of my ram!

Last response: in Memory
Share
March 25, 2011 5:50:42 PM

Hey all. Let me start off by saying yes, I have searched the forums and google for a solution to my problem, but so far, no luck. I have a Gateway FX6831 desktop with 8gb of ram, however windows 7 (yes it is x64) thinks I only have 4gb. It used to find all 8gb, and I have no idea why it's failing to now. Memtest (from within windows) finds 0 errors. Cpu-z does find all 8gb. I also updated my bios to the latest version, but it also only finds 4gb, and will not let me adjust the RAM settings at all. Does anyone have a solution?

Should you need to, you can find my full system specs here:

http://www.gateway.com/systems/product/529668627.php
March 25, 2011 5:52:56 PM

Professional, Ultimate, Home-Premium, Starter, Home-Basic, or Enterprise?
a c 346 } Memory
a b $ Windows 7
March 25, 2011 6:10:03 PM

Operating System Genuine Windows® 7 Home Premium (64-bit)-8
Memory 8192MB DDR3 Dual-Channel 1333MHz Memory-9
-8 Windows 64-bit versions are intended to work with 64-bit drivers and peripherals. Windows 32-bit compatible applications work in Windows 64-bit versions. For information about updating drivers and troubleshooting issues with device drivers for 64-bit versions of Windows, contact the manufacturer of the device or program or check the Microsoft website for additional information.
-9 Shared system memory may be allocated to support integrated graphics, depending on system memory size and other factors. Actual system memory available to the operating system will be reduced by the amount of dedicated and/or shared system memory utilized by the graphics solution and resources required by the operating environment.

After the Blah...Blah above, the 'PROBLEM' is OEM BIOS are for the birds. Chances are you cannot raise the DRAM Voltage.

So, there's a few things you can do:
1. BIOS Load Defaults
2. Windows, see image below, MSCONFIG set as shown {unchecked}
3. Verify that the BIOS can 'see' the RAM; use either CPU-Z {Memory tab} http://www.cpuid.com/softwares/cpu-z.html and/or the Resource Monitor. If the RAM is showing up as Hardware Reserved 2GB+ vs >20MB then apparently the BIOS 'thinks' the RAM is defective {9/10 too little voltage}.
4. Clean the RAM & DIMM slots: Use Isopropyl alcohol, dampen RAM contacts, insert into DIMM, clean and repeat -- allow to dry 5 minutes and FIRMLY RE-SEAT into DIMM Slots so the retainers snap-in.
5. Create a Memtest86+ CD/DVD; download and burn ISO {zip/ISO file} then run 4-passes.
6. Try (1) one stick at a time, see manual for proper DIMM slot 'typically the second from CPU, boot then try then next stick.

FAILURE RMA the RAM, do not send in 1 stick send them in as a SET.

MSCONFIG:


Resource Monitor:
Related resources
March 25, 2011 6:12:04 PM

Apologies and so forth, I've never had an OEM system but know that some versions of x64 Windows-7 only support upto 4096MB.
March 25, 2011 6:26:55 PM

i hav got a weired prob aswell my PC shows 4GB(3.25GB usable) and its x64 win7 ?? it use to show 4GB full earlier after i removed and reinstalled RAM i started getting this?? don knw may be i will take out and put RAM again but don think it wud work as it does detect both sticks
a c 346 } Memory
a b $ Windows 7
March 25, 2011 6:29:32 PM

@hitec16 - if your MOBO has an onboard VGA then the 'lost' RAM is shared with the onboard video.

@Omnisome - agreed, I needed to look myself.
March 25, 2011 8:08:01 PM

@jaquith: Thank you for your detailed and knowledgeable response. I've taken your advice step-by-step:

1) I reset the bios to its defaults; problem still unsolved, however.
2-3) Resource Monitor reports 4gb of ram hardware reserved, so apparently DIMM slots 3 and 4 have been quarantined.

I moved ahead to step 5 because it involved less risk to my machine. Memtest from within windows returned 0 errors as I said before, but I went ahead and tried out memtest86. Unfortunately, memtest86 would only test half of my ram! I tried changing the configuration mode to probe for more RAM, but without any luck. Is there anything I can do to force memtest to test my deactivated ram?
March 25, 2011 8:14:29 PM

Oh P.S., i've also heard that reseating your CPU sometimes fixes this issue. Should I try it?
a c 346 } Memory
a b $ Windows 7
March 26, 2011 12:02:32 AM

^The P55 most of all has been problematic with bent CPU pins, so it more an issue to discover bent pins than 'reseting' the CPU.

As 'BIOS Default' the RAM should be available and running @ 1.5v. Also, RAM needs to be installed as 'Matched Sets' so if it's mixed then that too can b a problem. Further, the RAM should be, at minimum, the SAME EXACT Frequency, CAS Timings i.e. 8-8-8-24, and must be of the same voltage.

Q - Are these ALL the SAME Sticks? Please post links to the RAM, you can use CPU-Z to identify the Part Numbers.
March 26, 2011 2:32:19 AM

Re: jaquith:

Yup, they are all the same sticks (Samsung 2048 mbyte PC3-10700, etc, etc), according to CPU-z. I recently reset my bios to default, but with default settings in memtest, yeah, as I said cpu-z knows that I have 8gb installed but memtest doesn't see them for some reason.
March 26, 2011 4:08:27 AM

jaquith said:
@hitec16 - if your MOBO has an onboard VGA then the 'lost' RAM is shared with the onboard video.

@Omnisome - agreed, I needed to look myself.


i hav a GTX460 video card so onboard mem must be disabled.IDK i will try some stuff up today and will update if any of them work for me.
a c 346 } Memory
a b $ Windows 7
March 26, 2011 12:51:30 PM

^ RE @hitec16 ONLY: Yeah, if your BIOS will allow you to disable the onboard GPU otherwise set the onboard to it's lowest value and disable it in Windows Device Manager. This ASSUMES @hitec16 has a Discrete GPU.

@brbrainerd - if the pairs got mixed-up, mark/note the locations first -- try 'Musial' DIMM Slots with the RAM, i.e. swap positions with the first two sticks.

Next, test DIMM Slots:

Typical Installation:
CPU: | Set2 | Set 1 | Set2 | Set 1 |

Trial 1:
CPU: | blank | Set 1 | blank | Set 1 |

Trial 2:
CPU: | Set2 | blank | Set2 | blank |

Both above should render 4GB, and if they don't then try Set 1 for Set 2 or visa versa. IF the DIMM slots are the bad then you'll need to send-in/repair the PC, otherwise it's bad RAM.

As I said, normally I'd suggest increasing the DRAM Voltage and/or {IMC} Voltage QPI/DRAM Voltage, but since I assume you cannot do this -- something needs to be sent back to GW.
March 28, 2011 3:57:22 AM

All right! As per your instructions, I started by swapping the first two sticks and suddenly Memtest86 and windows can use all of my memory. Memtest86 returned 0 errors across the board. Dubya-t-f?

I'm going to go ahead and mark this thread as [solved]. Big thanks to everyone who helped, especially you jaquith!
!