Sign in with
Sign up | Sign in
Your question

Windows was unable to complete the format

Last response: in Storage
Share
August 22, 2012 4:18:54 PM

I have just obtained 2 new 64gb USB 2.0 flash drives. One for my mother (Windows 7 Home), and one for my laptop (Windows XP Pro).
The weird thing is that they both work fine on Windows 7, but both of them are problematic on XP Pro.

One first told me it was not formatted and wouldn't allow me to complete the format. I checked the partition and it all seemed in order, but no file system was listed.

The second one looked ok when I popped it in. I copied some folders over. That worked well. However, when I created a new folder on the device it first appeared empty (With the name "New Folder"). When I changed the folder name a myriad of folders with odd characters in them appeared as well as files. All these folders and files and folders were not readable or accessible. The threw up errors when I clicked on the (single click).
I tried to copy files and folders into my newly created folder where all those weird ones appeared. The copy process seemed to go well, but when I examined the folder, my copied files were nowhere to be seen.

Each other new folder created on the device seemed to behave in the same way. I tried formatting in NTFS and that didn't work. So I tried formatting exFAT and that didn't complete either.

All these problems occurred in XP. On the Windows 7 machine everything seemed to work. It can't be a fluke for that to happen with 2 devices. My XP machine if free from viruses and Malware.

Has anybody come across this before?

What possible explanation could there be?

Jeff
August 22, 2012 5:58:00 PM

Did you buy them from a reputable dealer?
If not they could be smaller devices "Modified" to look like 64Gig; some markets (eBay for example) are flooded with the damn things.
!