Sign in with
Sign up | Sign in
Your question

Lan stops working while gaming

Tags:
  • LAN
  • LAN
  • Networking
Last response: in Networking
Share
March 12, 2010 6:09:43 AM

Hello guys, I know the community at Tom's hardware is the best around and since everyone else has failed me I figured I should seek advice from you guys. I have a custom built computer with a XFX nforce 750a amd mother board, amd 9550 phenom cpu, graphics card and all that, I dont think the other parts really matter for this issue. One that I think does is that the mobo has a built in marvell yukon lan, that and Im using windows 7 64bit ultimate.

My problem is that when I am gaming and only on higher end games like MW2, Fallout 3, Crysis, and Unreal Tournament 3, the lan stops working, forcing me to reset my computer to once again regain internet access. I mainly play MW2 and normally only get to play about 3-4 matches before I run into issues. My computer keeps connected to the internet but halts all traffic, it just goes to the yellow exclamation point. I tried to use the windows troubleshoot utility but that usually locks up when attempting to "reset Lan device" then I reset my computer and find that my Lan has been disabled, but only when I try to use the troubleshooting utility. I tried asking people at the main windows 7 forums which only led to dead ends, they just said stuff like "disable firewall and update drivers" I am an IT professional so I already know to keep my drivers up to date and all that. I had vista 32bit on this machine previously and never had any issues like this at all so Im running out of ideas and hope. I remember once seeing someone post something about onboard marvell devices shut down when the CPU cycles get high on windows 7 or something, that sounds plausible because it hasnt yet happen on my older games and stuff like Team Fortress 2, but I dont understand why it would do that after 2-3 matches on mw2 and not on the first one. Can any of you help me?

More about : lan stops working gaming

March 12, 2010 10:57:03 AM

If you have a second nic onboard, have you tried that one? You also might try an add-on pci or pcie nic as a test.
One other thing, if you have IPv6 running, TURN IT OFF. I have seen IPv6 cause problems before. Once I turned it off problems went away.
m
0
l
a b X LAN
March 12, 2010 2:12:51 PM

While I don't know what the problem is, anyone using w/ Windows 64 bit is going suffer from these sorts of odd problems for the next couple years until enough ppl are using it and these things gets flushed out. As soon as I see Windows 64 bit, I know anything's possible. It's like the IPv6 stack. It's new and everyone knows it's buggy.

Anyway, it might just be an issue w/ that LAN device. Ethernet cards are so dirt cheap I'd just try another and see what happens, esp. if you've been at this for a while.
m
0
l
Related resources
March 12, 2010 3:47:25 PM

I thought I had the ipv6 turned off, turns out it wasnt. Im going to go test it out and see if that works, thanks for the advice. I also remember seeing others have similar issues and they listed other optional features that do not need to be on, is there any others that you would suggest turning off?
m
0
l
March 18, 2010 5:51:01 AM

OK I tested it again and it is still having the same issues, have any of you found anything to fix this issue? Do you think a lan card would work?
m
0
l
March 26, 2010 11:36:30 PM

I have the same problem. My PC has P55A-UD3 with i5 stock, Ati 5770, 4GB 2ch Kingston RAM on Win 7 Ultimate x64. When I play GTA IV for more than... approx. 20 min, I notice that LAN stops (the yellow icon appears), and if I click "Troubleshoot..." it repaires itself ok. But the problem still repeats. I usually don't turn off my PC and the LAN doesn't ever stop except during the game. I haven't tryied with other games. In GTA IV benchmark results the CPU is at ~60% load. I also ran Prime and Intel Burst for more than 30 mins with 100% CPU load but the LAN did not stop. What could be the problem? Have someone discovered a solution yet?
m
0
l
March 29, 2010 9:04:29 PM

Well, after I disabled IPv6 it looks like the problem did not appear anymore. At least till now, I have played for 6 hours and the LAN did not stop.
m
0
l
March 31, 2010 8:15:48 AM

well... looks like the LAN still stops, but now randomly, not only in GTA. Anyways, it stops rarely... once in 1-2 days or something like that.
m
0
l
April 6, 2010 8:18:22 PM

Ok still having the same issues, but now I'm able to correct it via troubleshoot problems. Each time it tells me "the default gateway is not available" I have read up more on that since it seems to be a more narrow term than "lan quits working after a while" and some suggested that using a static ip could help, and that disabling ipv6 will not fix it and has ever fixed anything. Im going to try using a static ip and see if that works.
m
0
l
April 7, 2010 2:42:55 AM

Well I tried the static ip and it seemed to work worse than before so now Im back to square 1. I have a friend that also uses 64 bit windows 7 and he has similar issues but different hardware, so it is defiantly a windows issue.
m
0
l
!