Dx11 issues with dirt 2

hey guys, im in a predicament here. i upgraded from gtx 275 sli'd to the 480. still using one 275 for physx (is that a good idea?) ....dx11 works fine when using the heaven benchmark, avp also works fine, bbc2 is good. but when i load dirt 2, ill get the usual splash screen, opening credits blah blah blah. but right before i get to the main menu screen, my video just stops, but the audio still running. the game runs normally i can hear my button presses working fine, i just get no video. the only video that works is the little spinning loading icon on the bottom right of the screen, and the "press A to continue" . i forced dx9 by editing the xml file in the dirt2 folder, and that seems to work fine. i tried different resolutions in that same xml file, i tried both 197.41 and 197.45 drivers, uninstalled the drivers using the regular method in addition to driver sweeper, booting in safe mode, etc. ive uninstalled the game at least 4 times now, still nothing. i took out the 275 and tried it with just the 480 by itself, still the same issues. i used both hdmi and dvi connections to no avail. i need help guys, ive searched the net but couldnt find a definite solution.

also what was the first driver for the 480?

im running c2d 8400 oc'd 3.9 ghz, 4 gigs ddr3 crucial ram, windows 7 ultimate, 790i ftw mobo, 23" acer 1080p monitor
5 answers Last reply
More about dx11 issues dirt
  1. im also having issues with metro 2033, when i choose dx9 the game works fine, but when i try dx10 or 11, the video stretches to a ridiculous resolution, like 2040x250 or some crazy sh*t like that, any ideas why?
  2. There is no physX in Dirt 2, so you could try to turn off physX on the gtx 275 and see if that works.
  3. bystander said:
    There is no physX in Dirt 2, so you could try to turn off physX on the gtx 275 and see if that works.



    yea i did try that, but same result
  4. Must be something incompatible with the drivers for both cards. What OS are you using? Win 7 or Xp?
  5. bystander said:
    Must be something incompatible with the drivers for both cards. What OS are you using? Win 7 or Xp?

    7 ultimate
Ask a new question

Read More

Nvidia Graphics