Sign in with
Sign up | Sign in
Your question
Solved

500 gig hard drive no reporting only 302 gig available after removal of Ontrack

Last response: in Storage
Share
August 28, 2012 1:14:44 AM

Hello,
I'm having problems with a 500 gig HD origianlly on Win XP SP2 which formatted to 120gig/380gi partitions using seagate Ontrack manager. I trid to load Win XP SP3 which crashed the HD on a AMD Athlon 64 3800+ machine with 2 gog memory. I was unable to restart or re-initialize XP so reformated the drive with Win XP SP3 disc. Installation was fine but the 500gig HD now only shows 32 gig available and does not show any availbel etra space. Reformatting with Win 2K and then returning to Win XP SP3 didn't help. All checks appear to show that the number of head available is now only 2 instead of the original 16. How can I reset the number of heads to be used
a c 288 G Storage
August 28, 2012 9:28:11 AM

If the capacity is displayed as 32GB in BIOS, then use SeaTools for DOS to return the drive to its original factory capacity.

Otherwise try reinitialising the MBR using the FIXMBR command from XP's Recovery Console.
m
0
l
August 28, 2012 4:52:28 PM

Thanks for the assist. The Bios displays 33.8 Gig, running FIXMBR states that it has changed MBR, but after reboot I still have the same BIOS 33.8G. Running Seatools for DOS also will only operate on the same 33.8, but running the drive as a slave on a Win7 computer and using Seatools for Windows, the drive shows up as 500.1Gig with a 33.8Gig partitiona. All checks show good but when I try using Win7 Disc management, again all I can see is a 33.8 gig partition and nothing I have tried appears to remove the upper limit.
Still hoping to find someway of changing the boot sectors with Norton Disck Editor so that is will recognoze the full set of 16 heads instead of the 2 heads that it appears to be using. Any suggestions would be most welcome
m
0
l
Related resources
a b G Storage
August 28, 2012 5:04:40 PM

I would delete the partition, repartition, format, reinstall windows.
m
0
l
a c 288 G Storage
August 28, 2012 8:20:05 PM

You didn't specify your drive's model, but I suspect that you may have jumpered your drive for 32GB using its "Alternate capacity jumper".

Barracuda 7200.10 PATA Installation Guide:
http://www.seagate.com/support/disc/iguides/ata/1004023...

"Alternate capacity jumper: When this jumper is used, capacity is limited to 32 Gbytes. Use this jumper only if you have a legacy system with a BIOS that does not support large capacity disc drives. When using the alternate capacity jumper, DiscWizard Starter Edition software is required to achieve the drive’s full capacity."

Does your "AMD Athlon 64 3800+" machine's BIOS really need this jumper? If not, then remove it. Perhaps you set this jumper by mistake, by confusing it with the Master jumper at the opposite end of the jumper block. By rejumpering the drive as a slave, you would have removed the Alternate capacity jumper, thereby allowing the drive to report its full capacity.

Ontrack's Disk Manager software is an additional complication that can be removed by booting to your Recovery Console and using FIXMBR to rewrite Ontrack's DDO (Disk Drive Overlay) code. To do this, the optical drive must precede the HDD in the boot order. If the HDD boots first, then Ontrack's DDO code is loaded into RAM where it remains memory resident. This code provides INT13 extensions to the BIOS. Ontrack's DDO then relocates the MBR to a different sector (not LBA 0) so that Windows Disk Management can create a full sized partition table. If Ontrack's DDO boots before the optical drive, then your Recovery Console will see the relocated MBR, rather than sector 0, and FIXMBR will not overwrite the DDO code.

At least that's how Seagate's EZ-Drive DDO worked. It was used to circumvent the old 528MB CHS limit. Ontrack's DDO might work differently, but I suspect that the principles would be similar.
m
0
l
August 31, 2012 2:13:28 PM

The drive is a Seagate ST3500641A which is a 500Gig PATA drive which is 16383x16x63 giving 976772911 sector. My checks show it having 30.8 Gig with 16514064 sectors which looks as though it is only reading 2 head instead of 16. I have tried refomat, removing nd reonstalling partitions, removing and replacing various versions of windows and as I noted above the only way I can see a "500G" drive is with Seatools for Windows when run on a Win7 system, every other Windows operating system sees the drive as only 32.8 Gig. On eht Win 7 machine using Seagate Ontrack still only sees the drive as 32.8 gig, so I'm Ididn't bother trying to install Ontrack, but I guess I should try that to see what happens. I think that the main problen is that the Bios is reading the drive and only seein the 32.8 Gig. THat's why I think that I may need to know what location on the disc the Heads data is stored. The drive is being run on computers that are booting from SATA drives and the 32.8 Gig Drive is installed as Primary with a CD set as a slave, so there shouldn'gt b an issues, but I'm open to correction.
m
0
l
a c 288 G Storage
August 31, 2012 7:42:11 PM

Did you check the jumpers?

Barracuda 7200.9 PATA Installation Guide:
http://www.seagate.com/support/disc/iguides/ata/1003899...

"Alternate capacity jumper: When this jumper is used, drives with a 40-
Gbyte capacity or greater are limited to 32 Gbytes. Use this jumper only if
you have a legacy system with a BIOS that does not support large capacity
disc drives. When using the alternate capacity jumper, DiscWizard®
Starter Edition software is required to achieve the drive’s full capacity."

CHS addressing is a legacy concept. AIUI, Windows takes the drive's reported capacity and fudges the CHS values to suit. The drive doesn't actually report these particular numbers.
m
0
l
September 1, 2012 12:17:39 AM

Sorry, I mossed answering that one - there are no jumpers fitted so the drive is not limited to the 32 gig and it did originally format to 500G when using OntrackThe computer, now with Win XP SP3 does not have a limitation and now has a 1Tb drive installed with no issues

m
0
l
a c 288 G Storage
September 1, 2012 1:21:38 AM

You really need to decide just how big your drive is. Is it 30.8GB, 32.8GB, or 33.8GB?

"The Bios displays 33.8 Gig"

"My checks show it having 30.8 Gig with 16514064 sectors"

"every other Windows operating system sees the drive as only 32.8 Gig"

"Bios is reading the drive and only seein the 32.8 Gig"

"The drive is a Seagate ST3500641A which is a 500Gig PATA drive which is 16383x16x63 giving 976772911 sector"

976772911 sectors x 512 bytes per sector = 500 107 730 432 bytes

CHS = 16383/16/63

16383 x 16 x 63 = 16 514 064 sectors

16514064 sectors x 512 bytes per sector = 8 455 200 768 bytes = 7.87 GiB

I don't understand what you mean by the following statement:

"Running Seatools for DOS also will only operate on the same 33.8"

Are you running SeaTools from a bootable CD, and does the optical drive appear before the HDD in the BIOS boot order?
m
0
l
September 1, 2012 1:36:09 AM

Depending on the tool I use, I get different answers for size, but for ease lets call the small version 32G for ease and the original size as 500G. The sector sizing I noted again from various tools. I really should go back through my sequence and note exavtly which tool ive which set of numbers. I hadn't run the mubers to check to validity of the results> I recall that one tool noted that 1024 appeared to be the bytes per sector . I will retyr the tools and return with a better set of results.
I have been running the bootable Seatools disk and only get the 302G, but if I run the Seatools for windows, I get 32G with XP and 500G with a 30G sub disc witn Windows 7. This shows whether or not I actually have a formatted partition . The DOS Boot Seatools shows 2 options 1 HDD boot and 2 CD boot.
m
0
l
a c 288 G Storage
September 1, 2012 2:57:45 AM

The following article appears to explain what you may have done (by using Ontrack Disk Manager):

63 Sectors BIOS limit:
http://www.allensmith.net/Storage/HDDlimit/63Sector.htm

Notice that the BIOS limitation of 31.5GiB (33.8 billion bytes) corresponds to CHS values of 65536/16/63.

Therefore ISTM that the drive was installed in a system with a 33.8GB BIOS limitation, and that Ontrack's Disk Manager was used to provide a workaround. If you are booting directly from a SeaTools for DOS CD, with the optical drive appearing *before* the HDD in the boot order, then SeaTools is telling us that the drive's capacity has been reduced by means of a HPA. In this case you should be able to use SeaTools to restore the drive's maximum capacity.

See http://en.wikipedia.org/wiki/Host_protected_area

Alternatively, if the HDD appears before the optical drive in the boot order, then Ontrack's Disk Drive Overlay (DDO) will be loaded into memory. This DDO code would then prompt you whether you wish to boot from the CD or from the HDD. This is necessary so that the software on the CD can see the full size of the HDD (via the DDO). If you boot to SeaTools *after* loading the DDO, then anything you do with SeaTools will be intercepted by the DDO, in which case you cannot be certain that SeaTools will be able to do what you want it to.

After restoring the drive's full capacity, you must not immediately reboot it. If you do, then the DDO code will be executed, and any changes may be undone. Instead, you must boot to a Windows XP Recovery CD and execute the FIXMBR command. This will overwrite Ontrack's DDO with standard Microsoft code. Alternatively, if your data are not important, you could use SeaTools in your previous step to write zeros to the first track on the drive.
m
0
l

Best solution

a c 288 G Storage
September 2, 2012 12:31:08 AM

ISTM that Ontrack's Disk Manager works a little differently to the old EZ-Drive DDO I alluded to earlier. I could be wrong, but I believe the following may explain what your are seeing.

The old BIOS had a 33.8GB limitation. To circumvent this limit, Disk Manager reduced the capacity of the drive by means of a HPA. The drive then reported a size of 33.8GB via the ATA Identify Device command which is used by BIOS to determine the physical characteristics of the drive. This same capacity would be reported in any system in which this drive is later installed.

BIOS accesses hard drives and floppy drives via system calls to Interrupt 13 (INT13). As hard drive capacities increased, and new features were added, IBM's original INT13 functions were extended. These INT13 extensions enabled various capacity barriers to be circumvented, eg 528MB, 8GB, 32GB, 137GB, 2TiB. For example, 48-bit LBA support was added to get around the 137GB limit.

http://en.wikipedia.org/wiki/INT_13H

When BIOS updates are not available, as appears to have been the case with the original motherboard, these INT13 extensions need to be provided in software. To this end, Ontrack's Disk Manager installs its own DDO code in sector 0, and elsewhere on track 0. This code is loaded into system RAM at bootup and remains memory resident. Ontrack's DDO would include an INT13 extension that would enable the drive's entire 500GB capacity to be accessible. It would do this by intercepting all disc accesses (ie by "hooking" INT13) before passing them on to BIOS.

Another thing that the DDO would need to do would be to expand the drive's capacity to the full 500GB. It would need to do this by executing the ATA SET MAX ADDRESS or SET MAX ADDRESS EXT commands. See Section 4.11 of the following document:

Working Draft AT Attachment 8 - ATA/ATAPI Command Set (ATA8-ACS):
http://www.t13.org/documents/UploadedDocuments/docs2008...

There are two options for these commands, either volatile or non-volatile. In Ontrack's case the volatile option is used, which means that the drive reverts to reporting a 33.8GB capacity after a power-on reset. In SeaTools' case the Set Max Capacity menu option is non-volatile, which results in the drive retaining its full factory capacity after a power cycle. The catch is that the capacity can only be changed once during each power cycle. This means that, if Ontrack's DDO has expanded the drive, then any subsequent changes by SeaTools would be ignored. Therefore SeaTools must be booted before the DDO in order for its changes to have any effect.

The problem with reducing the drive's capacity to 33.8GB is that, if you attempt to install Windows XP directly from a Win XP CD, Windows will only see 33.8GB. Instead, you would need to boot to the HDD first. This will load Ontrack into memory, its DDO will expand the drive, and Ontrack will then prompt you whether you wish to continue to boot from the HDD or the CD. If you choose the CD, then the Win XP installation can proceed as usual, with the drive's full capacity being visible.

After Windows boots, its own drivers take over from BIOS, so the DDO code is not required until the next boot.
Share
September 2, 2012 4:32:44 PM

Still trying the options you have suggested. However, is appears that no matter how I set up the Computer Bios in both machines that I have (Old Pentium 4 and newish AMD AM3 Phenom) the POST still reports seeing the 32G. I'm now trying booting the AM3 from a win7 system repair disc but this is unfortunately repairing the 32G. Will re-install a floppy and revert to the old Seatools DOS to see what I get them.
m
0
l
a b G Storage
September 3, 2012 8:48:22 PM

Quote:
I would delete the partition, repartition, format, reinstall windows.
m
0
l
a c 288 G Storage
September 3, 2012 9:01:15 PM

@perkydj, it appears I'm not a very good communicator.

The reason that fiddling with BIOS, or deleting, repartitioning, and refomatting will not fix anything is that the 500GB drive actually thinks it is a 32GB drive, and it is telling the world, including BIOS and Windows, that it is a 32GB drive. That's how a HPA works.

SeaTools for DOS will fix your problem by removing the HPA.
m
0
l
September 4, 2012 12:54:43 AM

Thanks for all the advice and assistance on this. I have tried using every Seatools ( DOS and Windows) without any luck. I have tried rebooting after every attempt, andI have tried with the 32G ( of 500) connected as a single drive and as a slave. The drive is a PATA and I have tried it connected to both SATA and additional PATA HDs and with every operating system from Win 98 to Win 7. I also tried using Norton Disc Editor to change data with no luck. I have used a WIPEDisk program to completely clear the disc and have also deleted partitions and reformated with both FAT and NTFS. All with no luck. The latest attempts were with Ultimate Boot CD (MHDD.exe) program, but I had no luck getting that to run. However as part of that review I can across the following in the FAQ and that led my to http://blog.atola.com/restoring-factory-hard-drive-capa.... There I found a program HDD Capacity Retore Tool, I downloaded it and with the 32G drive connected as a master on the IDE controller and a SATA as the boot drive, this program (crsetup.exe) allowed me to reset the HD from 32 Gig back to its original 500G. Hope this is useful to others . Thanks again to all
m
0
l
a c 288 G Storage
September 4, 2012 6:19:23 AM

Congratulations. That said, I don't undersand why you couldn't get the same outcome with SeaTools. Ironically, I have often recommended the HDD Capacity Restore Tool, but many people have reported that it didn't work for them, presumably because some Windows driver didn't cooperate.

MHDD should also have worked. The only time I've seen people have trouble with it is when the drive is a SATA, and they haven't been able to reconfigure the SATA controller in BIOS for legacy or IDE compatibility mode.

Other tools that should have been able to remove the HPA are HDAT2 and Hitachi's Feature Tool.
m
0
l
September 9, 2012 2:21:04 AM

Best answer selected by perkydj.
m
0
l
September 9, 2012 2:26:36 AM

Fzabkar, your message on 8/31 was the one that gave me the final approach to resolving the issue. Many thanks. I really don't understand why Sealtools didn't solve the issue, nor why MHDD had problems, but I will remember all of them for future problem of this type
m
0
l
!