Sign in with
Sign up | Sign in
Your question

MASS STORAGE DEVICE PROBLEM

Last response: in Systems
Share
July 2, 2010 2:13:54 PM

Hi everyone

I have just built up a new computer and installed Windows XP Professional.
I have had no problems except when I plug in a flash drive (aka memory stick, usb drive, usb thingy) Window goes to the "Found New Hardware Wizzard". Then when I go through the wizzard it eventually says "The file USBNTMAPS.sys on Unknown is needed. Type the path where the file is located and then click OK."

First of all I don't know where the file is, but that is not the big problem. The big problem is that when you normally plug a flash drive into a computer you don't need to go through a setup wizzard.

This is the first time I have ever had this problem, between my 4 PC (Vista Home Premium 32 BIT, Windows 7 Ultimate 64 BIT, Windows XP Professional, Windows XP Home Edition).

All my other USB Devices work, the problem is only with USB Mass Storage Devices. All my USB Mass Storage Devices work on my other PCs, but not on this one.

Any ideas?
a b B Homebuilt system
July 2, 2010 4:09:31 PM

My guess is a driver issue. Make sure driver's are up to date for the USB controllers, and chipset in general.
Anonymous
a b B Homebuilt system
July 2, 2010 4:15:32 PM

Sometimes it happen by not detecting a usb drive, You may want to try diff port first.
Related resources
July 2, 2010 4:47:45 PM

Tried different ports and all drivers are up to date. The problem is only with mass storage devices, all other usb devices such as mouse and printer work fine.
July 2, 2010 4:49:11 PM

It detects the drive fine, the problem comes in when installing the drive. See post above.
!