Sign in with
Sign up | Sign in
Your question
Solved

HD 4850 locking up

Tags:
  • Graphics Cards
  • Graphics
Last response: in Graphics & Displays
Share
May 24, 2010 11:29:51 PM

I recently finished a build with:

i7 930
MSI x58 pro-e
Corsair XMS3 4GB Dual Channel DDR3 RAM - - PC10666, 1333MHz, 4096MB (2x 2048MB)
HD 4850
OCZ StealthXStream OCZ600SXS 600W

I am trying to play MW2 on max settings and it runs smoothly but every 20 minutes or so I hit huge lag spikes and my frames drop to single digits. I know that this card can run MW2 on max because my friend has the same card with a slower cpu and he runs it fine. I ran a 3DMARK06 benchmark and only scored 8671 so I am assuming that there is something wrong.

I have checked the temperatures, reinstalled windows 7, updated all the drivers/made sure to fully uninstall the old ones, and tested the RAM. Anyone suggestions as to what could be wrong?

SM2.0 Score: 3357
HDR/SM3.0 Score: 3208
CPU Score: 5107
(1920x1080, 4 sample AA, Anisotropic 16x filtering)

More about : 4850 locking

a b U Graphics card
May 24, 2010 11:41:42 PM

Could have a bad Motherboard. MSI is notorious for buggy motherboards. My company quit using them in our builds a couple years ago because they crash so much. Go with an ASUS or Intel Board if you can.
m
0
l
May 25, 2010 1:03:16 AM

Hm ok, is there anything I could run to test it?

Also are these benchmarks really low for what I have?
m
0
l
Related resources
a c 189 U Graphics card
May 25, 2010 7:59:34 AM

Have another card?

Or you can try your card in another computer to make sure whether the same problem exist or not...

maybe you might want to lowering the resolution, 1920x1080 is just too high for HD4850...
m
0
l
a b U Graphics card
May 25, 2010 8:10:47 AM

second the MSI being uber rubbish i cant say it enough there just not a good manufacturer

do the usual tests - prime95, atitool/furmark etc
m
0
l
a c 232 U Graphics card
May 25, 2010 4:34:08 PM

Your 4850 should run the game without any issues. Do you have similar lags when using other games? Also, have you looked at your Event Viewer to see what errors are being logged? What other apps are running in the background when this is happening? Bottom line, need to troubleshoot the easy before swapping MBs.
m
0
l
May 25, 2010 10:27:37 PM

Thanks for the advice everyone.

apache: I ran prime95 and furmark for an hour or two and did not crash, my temperatures didn't spike or anything either.

COLGeek said:
Your 4850 should run the game without any issues. Do you have similar lags when using other games? Also, have you looked at your Event Viewer to see what errors are being logged? What other apps are running in the background when this is happening? Bottom line, need to troubleshoot the easy before swapping MBs.


The only other game that I have tried is Counter Strike Source which runs fine without any lag spikes.

I am not running anything else in the background. I have Microsoft Security Essentials and driver software for my MX518 mouse but that is it.

What should I be looking for in the event viewer? The only thing I see that comes up a few times is atikmdag with a description of "Display is not active". A quick google indicates that this error has something to do with the display driver. Do you think this could be causing my lag spikes?
m
0
l

Best solution

a c 232 U Graphics card
June 2, 2010 1:15:16 AM

Could be part of the issue. A suggestion would be to completely remove ATI drivers/Catalyst and install the most current version for your OS to see if it clears up the lag. You definitely have a little something bonked with the ATI driver install, but I doubt it is significant enough to cause the lag with one game.

regarding what to look for in the Event Viewer, you generally look for crashed (anything other than a normal indicator), especially around the time you experience a problem (like playing your game or a crash). Just a good way to pinpoint a problem.

One last question...are you using 32 or 64 bit Win7?
Share
June 2, 2010 1:36:24 AM

Just as a heads-up, I had a similar issue with the game. On my machine, the MW2 executable would starting using more and more RAM, until the exe was taking ~80% of my it, and had started paging to RAM, causing the slowdown.

The only solution I found was to just restart the program. :/ 
m
0
l
June 2, 2010 10:11:15 PM

Best answer selected by nortonav.
m
0
l
June 2, 2010 10:13:35 PM

Thanks. I picked up another 4850 for crossfire and reinstalled all of the drivers and it seems like I have stopped lagging. I do not think it was a problem with my video card because MW2 was consuming all of my ram and causing me to crash.

If you have this problem change your textures from manual to automatic, changing this setting fixed it for me.
m
0
l
!