Sign in with
Sign up | Sign in
Your question
Solved

Unable to secure erase - Crucial M4 SSD

Last response: in Storage
Share
August 29, 2012 2:54:49 PM

Hi guys,

I just purchased a bunch of parts last week for a new build and have put it all together now. Please excuse my terminology as I'm still relatively new to building computers.

I installed Windows 7 Home Premium, but received an amazing deal on a new copy of Windows 7 Ultimate. Last night, I downloaded Parted Magic and installed it on a bootable USB drive so I could secure erase the SSD. The first problem is that when I boot to the USB drive, I get the main menu for Parted Magic - and I lose keyboard/mouse control (wireless). I hooked up an old PS/2 keyboard, and a wired USB mouse and was then able to navigate within Parted Magic.

Now, the default option for Parted Magic should be "XORG" but when I try to load this (with default settings - running off of RAM), it seems as though it tries to load the Parted Magic desktop - but eventually times out after 5-10 seconds and then I'm back to the main menu. I can get to the Parted Magic desktop by using "XESA" - not sure if this is a major issue or not. I tried to search around on Google in regards to this but the people posting about this mostly talk about Linux distros which is a foreign language to me.

Once I'm loaded in to the Parted Magic desktop, I try to Secure Erase my SSD and I get an error message stating that the SSD is in a "frozen" state and that it cannot be secure erased. I did some searching on Google for a resolution for this as well. I tried to use the "sleep" option - no go, still "frozen" state. I restarted the PC several times as well but could not get the drive to "unfreeze". Finally, I booted into Parted Magic with the SSD SATA cable unplugged, plugged it in, and I was able to Secure Erase it. I was then able to install Windows 7 without any issues.

I was curious this morning so I tried to boot into Parted Magic again to see if it would let me Secure Erase the drive again but to my surprise, the drive was frozen again!

The SSD is a Crucial M4 256 GB - 000F firmware (was already updated when I purchased it). My searching so far keeps coming up with people having this issue with OCZ drives but they are able to use the OCZ toolbox to resolve their issues. Is there something I'm missing for Crucial? I see that they don't offer anything like this.

Could this be a sign of a bad SSD drive? I have 2 more days to return/exchange the drive so if it's going to be giving me problems in the long run, I figure I might as well go exchange it. Also, I've read about the program HDDErase, should I try this instead? Also, I was in AHCI mode when I was doing this, should I be in IDE? I keep reading conflicting posts on this.

I apologize for the long post, I stayed up late last night trying to get this new PC all set up and want to ensure that I don't have any faulty parts.

I'm not sure if it's needed but here's the rest of my system, if you need any more information, please let me know:

Processor: Intel i5 3570K
Motherboard: Asus P8Z77-V
RAM: G.SKILL RipJaws 8 GB DDR 3 (1600 MHz)
a b G Storage
August 29, 2012 4:10:22 PM

Why don't you just do a fresh install of the new OS over the old OS and reformat the drive when prompted?
August 29, 2012 4:21:28 PM

ram1009 said:
Why don't you just do a fresh install of the new OS over the old OS and reformat the drive when prompted?



Thanks for the reply.

I can definitely do that but I just want to ensure that the drive being in this frozen state is not due to any defects with the SSD. I mean, I should be able to do secure erase with no issue right? I'm reading that it's the BIOS that causes this locked/frozen state, my BIOS settings are still set to default so I'm not sure how I can resolve this.

I'm probably overreacting, it's just that my searches so far haven't really shown a lot of people having this problem with the Crucial M4s - I'm mostly seeing posts about the OCZ SSDs.
Related resources

Best solution

August 29, 2012 5:18:09 PM
Share

I highly doubt the issue is your SDD being defective. Seems this is normal behavior for SSD in Parted Magic.

Try the suggestions in the following article:
http://www.overclock.net/t/1227597/how-to-secure-erase-...
August 30, 2012 7:13:19 PM

Best answer selected by sparmar7.
!