Windows 7 p8p67 bios hanging

Hello,

I have a problem with my newly built system. I have an Asus P8P67 m/b with an Intel i5 2500k 4Gb DDR-3 RAM, a Crucial C300 64Gb SSD & Spinpoint 500Gb HD. The problem is that when it boots up it spends about 3.5 minutes hanging on the BIOS splash screen before it finally boots into Windows 7 (64-bit). Once running everything works OK.
I have flashed the latest version of the BIOS (1401), I have no other boot devices.
Anybody any thoughts as to why it should take so long to boot up ?
thanks for your help

Bodders
7 answers Last reply
More about windows p8p67 bios hanging
  1. Welcome to Tom's Forums! :)

    Q - What changes have you made to the BIOS e.g. AHCI, etc.
    Q - What SATA Ports are being used with what?

    Next, check the version of firmware on the C300 -> http://www.crucial.com/support/firmware.aspx update if needed. However, you might need to reinstall the OS; you've been warned.

    If you switched to AHCI then see this link to check the registry -> http://support.microsoft.com/kb/922976 ; note you don't always get an error message...
  2. Jaquith

    Thanks for your reply. Here are my answers :

    I've made no changes to the BIOS - using default settings only.
    I'm using the 6Gb Intel ports for the SSD and the HD.

    The firmware for the C300 is the latest revision - 0006.

    I tried the registry fix & it still hangs on the BIOS splash for 3/4 mins before booting up

    Can you suggest anything more pls

    Bodders
  3. Move the C300 to the Intel SATA2 ports. If it boots fine then move back to the SATA3 port; this will reinitialize the Drivers. Next if failure, you'll need to delete the driver manually in the Device Manager and restart.
  4. Jaquith

    I tried moving the C300 to the SATA2 port, booting, moving them back to the SATA3 but it did not work.

    If I remove the driver manually using Device Manager does this mean a re-install, or just a restart/reboot ?

    Thanks for your help

    Bodders
  5. Quote:
    restart/reboot ?

    Thankfully just reboot, it reinstalls the Driver and rewrites the registry values {e.g. can correct corruption of either driver or registry}.
  6. Jaquith

    Unfortunately that had no effect either. It's still hanging on the BIOS splash screen for 3-4 minutes & then it boots in & all works OK.

    Any more thoughts ?

    Bodders
  7. If it seems not to be the SSD. Next is more complex to determine.

    Short of a full breadboard:
    * BIOS Load Defaults
    * 1 Stick of RAM in the 2nd DIMM Slot from the CPU
    * Remove all of the Front Panel and USB Panel connections
    * Disconnect ALL peripherals including Keyboard and Mouse; anything USB.
    * Unscrew the MOBO and PCIe screw, dangle the MOBO supported by a towel.

    Use either a screwdriver or wire and short the PWR+ and PWR- {Ground}.

    'Guessing' is impossible, the source problem needs to be identified.
Ask a new question

Read More

Chipsets BIOS Windows 7 Motherboards