Sign in with
Sign up | Sign in
Your question

BIOS not detecting HDD as boot option

Last response: in Storage
Share
August 31, 2012 2:27:32 AM

As the title says, in my motherboard's GUI, I'm not seeing my HDD as a boot priority.
My boot options with my HDD unplugged from the sata port:

AHCI p0 Corsair (SDD)
AHCI P3 opticar dvdr
uefi optiarc dvdr


When I plug my HDD into the SATA port on my motherboard, sometimes it won't even show my SSD or my dvdr.

My hdd and ssd share a power cable, but use separate sata data cables.

My dvdr has a separate power and sata data cable.

What's going on here? Why can't it detect all three?

Also, there's a 3rd unused port on my HDD. It's a small 8-pin male slot that I have no cord for or anything.

Thanks for the help!
a b V Motherboard
August 31, 2012 2:32:44 AM

What board? Have you checked the BIOS updates?

It's trying to detect the HDD and failing, at which point it stops trying to see the others if it has not already.

Which ports? are they different colors on the board?
m
0
l
August 31, 2012 2:37:01 AM

ASRock z77 Extreme 4. It's a new build - Haven't even installed windows yet. So no new mobo drivers or anything

I've tried it in all different ports. My SSD is plugged into the gray sata3 port. There's 2 slots on that, so I initially tried having both SSD and HDD on the gray slot. I've since tried the black slots.

I don't know at which point it fails. When I go to the mobo gui to chanbe boot priorities, it just shows the SSD and two options for the dvdr
m
0
l
Related resources
August 31, 2012 2:43:39 AM

EDIT: It seems to be only detecting the drive that's plugged into the bottom gray slot on my mobo. The other slots fail.
m
0
l
a b V Motherboard
August 31, 2012 2:48:15 AM

Well, other things to check would be the data cable for that drive.

Also, your board has four SATA 2 and four SATA 3 ports. Make sure the HDD is in a SATA 2 port for troubleshooting.

What HDD is it?
m
0
l
a b V Motherboard
August 31, 2012 2:49:14 AM

cwenk said:
EDIT: It seems to be only detecting the drive that's plugged into the bottom gray slot on my mobo. The other slots fail.


Well, that would certainly indicate a bad board.
m
0
l
August 31, 2012 2:52:36 AM

Well, that was an exaggeration. Here's a more specific account:

I have my SSD plugged into my Sata3 gray slot,
DVDR Plugged into a black sata2 slot.

I boot, it detects both fine.


I power off, connect my HDD to a SATA2 OR Sata3 slot, boot up, and it ONLY detects my SSD (the DVDR is now missing).

So far, this seems to work like this interchangeably between my SSD and HDD. I've been able to detect my HDD and DVDR. I've been able to detect my SSD and DVDR. But not all three.
m
0
l
August 31, 2012 3:00:30 AM

Asrubbish? Not surprised. I'd RMA it and get a quality board from Asus or Gigabyte.
m
0
l
a b V Motherboard
August 31, 2012 3:01:20 AM

I think I would update the BIOS then.
m
0
l
August 31, 2012 3:05:54 AM

How would I go about this without having an OS installed?

Edit: or should I just install windows to the ssd for now and worry about getting the hdd working after everything is updated?
m
0
l
a b V Motherboard
August 31, 2012 3:29:51 AM

No update the BIOS. Follow the directions in your motherboard manual. No drive needs to be present.
m
0
l
November 12, 2012 1:45:55 PM

Hey Cwenk. I am in the process of building my first build so I may not be the best or most knowledgeable to advise you on this, but I am using the Asrock Z77 Extreme 4 as my mobo and I have the Zalman Z11 plus case. It says that if eSATA 3 port on the rear i/o shield has been connected, the internal SATA 3_A1 will not function. Not sure if this helps but good luck
m
0
l
!