Sign in with
Sign up | Sign in
Your question

P67 Sabertooth no 5.1

Last response: in Motherboards
Share
April 4, 2011 6:11:04 PM

Can anyone help me? I have no option for 5.1 or 7.1 optical audio under the advanced settings in properties. I only have 2 channel options. My old gigabyte ud4 was the same until I updated the bios. The properties then had the dolby upmixing section with dolby prologic II. I only want 5.1 for watching movies. Do I have to wait for a bios update?

More about : p67 sabertooth

a c 207 Ĉ ASUS
a c 715 V Motherboard
April 4, 2011 6:47:12 PM

My assumption this is a set-up problem and not a BIOS problem, and I assume everything is up to date and installed properly.

In the BIOS:
The following needs to match up with your source out.
HD Audio Controller [Enabled]
Ft Panel Type [HD] ; AC97
SPDIF Output [SPDIF]

See Manul page 4-4; the access is in the Task bar 'Realtek HD Audio Manager'

Verify the outputs and set-up:
]

Verify the outputs:
April 4, 2011 7:10:53 PM

I have the bios set up that way but I do not use any front panel (front spdif) so it is disabled. Realtek digital output(optical) still does not have any options other than 2 channels
Related resources
a c 207 Ĉ ASUS
a c 715 V Motherboard
April 4, 2011 7:42:28 PM

What physical output connections are you using? What's the PC connected to? Remember WMA files will not playback on the S/PDIF.

From above Sound/Playback is from my ASUS P6X58D-E. So if I were to connect to my rear S/PDIF I would first connect the disconnect any Analog outputs, connect output to the optical @ rear I/O, and use the Digital Output (Optical) tab {press the Set Default Device} from the Realtek HD Audio Manager. Verify Sound/Playback = Digital Output (Optical).

In my case I have Coaxial / Optical S/PDIF out ports {Digital}.
April 4, 2011 9:48:03 PM

I only use the optical for movies everything else is megalodons for games and music.
I don't use spdif for anything.

Optical works but only 2 channels when connected to my receiver.
a c 207 Ĉ ASUS
a c 715 V Motherboard
April 4, 2011 11:18:46 PM

I just tried my ASUS and updated the image above. You need to also click the DVD Format button. Both my PC and Receiver both use 24-bit, the DVD {Menu} was set to Dolby 5.1 {tried Star Wars}, and my Player supports Dolby.

So any of those might cause a problem. Also try disconnecting the 'other' analog outputs.
April 12, 2011 7:44:11 AM

hmm i will have to try these
September 10, 2011 7:12:32 PM

o brother i also face the same problem.still didnt got any solutions!!
i think i have to download some "codec" or some thing to provide a 5.1 spdif optical output.something called dts connect or dts interactive.
i didnt tried that.help me too
September 17, 2011 6:43:21 AM

zoom player works if you enable spdif
a b V Motherboard
September 17, 2011 7:22:54 AM

alphi99 said:
o brother i also face the same problem.still didnt got any solutions!!
i think i have to download some "codec" or some thing to provide a 5.1 spdif optical output.something called dts connect or dts interactive.
i didnt tried that.help me too


You aren't going to get 5.1 dolby digital live or DTS connect coming out of the motherboard's coax or optical port. You need a sound card for that.

Re: jaquith's pics - are you saying that you need to press the DVD button to enable a 2 channel digital out to carry a 5.1 encoded stream to output to a receiver that will decode it in 5.1? Previously I have always left the digital at 2.0 channels in the setup and when I play a dvd or bluray it sends the stream and voila! 5.1 emerges from the receiver. Not sure why you would need to press DVD. Some DVDs are only in 2.0...
!