Sign in with
Sign up | Sign in
Your question
Solved

HDD won't boot after installing SSD

Last response: in Storage
Share
September 1, 2012 5:36:48 PM

I wanted to go back to my Windows 7 on my HDD to see some of the settings I had, but it won't boot. I switched to AHCI before installing Windows 7 on my SSD, could that be the problem?

Best solution

Anonymous
a b $ Windows 7
a b G Storage
September 1, 2012 5:53:49 PM

if the HD was installed with IDE enabled, yes. if you are temporarily using the HD then switch to IDE in the bios. make sure you switch back to AHCI to boot off the SSD.

if you think you may swtich from time to time then change the HD to ahci by using these steps and rebooting:
Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click one of the following registry subkeys:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
In the right pane, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.

reboot, change to ahci in the bios and you won't need to worry about it again.
Share
September 1, 2012 6:24:48 PM

Anonymous said:
if the HD was installed with IDE enabled, yes. if you are temporarily using the HD then switch to IDE in the bios. make sure you switch back to AHCI to boot off the SSD.

if you think you may swtich from time to time then change the HD to ahci by using these steps and rebooting:
Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click one of the following registry subkeys:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
In the right pane, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.

reboot, change to ahci in the bios and you won't need to worry about it again.


Does it matter if I do both Msahci or IastorV?
m
0
l
Related resources
September 1, 2012 6:56:04 PM

Best answer selected by bigant262.
m
0
l
Anonymous
a b $ Windows 7
a b G Storage
September 1, 2012 7:10:17 PM

you need to do both.
m
0
l
!