Sign in with
Sign up | Sign in
Your question
Solved

Dual 5770 crossfire problems bios I think

Last response: in Graphics & Displays
Share
May 28, 2010 12:23:15 AM

Ok I'll start out with system specs then my problem

phenom II 965 3.4
biostar 790gxa3+ http://www.biostar.com.tw/app/en/t-series/introduction....
5770 1gb x2 http://www.newegg.com/Product/Product.aspx?Item=N82E168...
4gb ddr3 ram
windows 7 ultimate


Ok I've called tech support at xfx and they told me to tryout taking each card out and seeing what the
3d mark 06 score was to make sure that they are operating correctly, and yes they are both posting the same scores.
Funny thing is when i'm in crossfire mode with both cards im posting same scores too.
I am using the bridge they provided, my motherboard manual talked about a 4pin molex to add extra power incase of crossfire, ive plugged this in and im pretty stumped..
I don't really have anything else to benchmark it on because the 3d vantage only lets you run it once..

I know there has to be a bios setting im missing somewhere on that biostar site
http://www.biostar.com.tw/app/en/t-series/introduction....
you can click manual and load up a pdf on the motherboard and the bios i'm not really that familiar with playing with bios I'm scared to even oc my black edition phenom lolz so...
all ive done is gone to bios is change

AMD 790GX Configuration-PCI Express Configuration-GFX Dual Slot Configuration < to enabled from disabled

I appreciate you reading my post and any info anyone can provide thanks guys, gals..
May 28, 2010 2:58:57 AM

anybody take a stab at it
May 28, 2010 5:01:32 AM

I'm not really an expert at this but I'll take a shot at it since no one else seems willing. It may be a problem with your mobo not supporting xfire or the slots are malfunctioning.
Related resources
May 28, 2010 5:34:19 AM

thanks for taking a stab
a c 376 U Graphics card
May 28, 2010 10:38:37 AM

The only thing I'm seeing in the BIOS that may affect things is the "GPP slots power limit" setting. I know the PCI-E x16 specs are supposed to be for the slot to deliver 75w so you may want to try raising it up to 75. Other than that try disabling the onboard video if you haven't done that already.
In general for this problem I would think it's more Biostar's customer service you'll want to contact rather than XFX so give that a go maybe.
Have you tried using actual games to benchmark? You can use fraps or rivatuner to get an in game display of frames per second. Just disable crossfire in catalyst and check the frame rate then enable it and run the game again. The differnce should be obvious and games that don't scale in crossfire are rather rare these days so pretty much any vaguely recent game should work.
You may want to try reinstalling your drivers as well. Uninstall then boot up in safe mode and run this;
http://www.guru3d.com/category/driversweeper/
Then install the latest catalyst control center from the AMD website.
Otherwise it could be something as simple as a defective crossfire link cable which would be much more convenient than a faulty card or motherboard.
May 28, 2010 6:47:11 PM

i have almost the same set up. sounds like a dud pci slot. did you turn on crossfire support in ati catlyist?
May 28, 2010 11:26:26 PM

nope i havent turned off the integrated but didn't think it would work with my card anyways because its not xp or vista...

I knew it would have to be something like the amount of power per card

i'm starting to think if all this doesn't work and the new crossfire cable in the mail doesnt work... its rma time on my motherboard..
May 28, 2010 11:28:45 PM

oh and my framerate is just the same as if i had 1 card
May 28, 2010 11:29:40 PM

oh and btw biostar doesn't answer their phones today, LOL and not replying to me email from yesterday
May 28, 2010 11:39:48 PM

i got ati crossfire thing to showup on whatever is supported from bottom right so it has s big ati crossfire at top right in the games, funny lolz I think im gonna just diable ai until I get some sort of response from biostar but im not holding my breath
May 30, 2010 12:01:22 AM

Ok well i'm going to fresh install windows 7 lets see if that helps...
May 30, 2010 12:14:34 AM

Have you tried updating your bios?
May 30, 2010 1:00:31 AM

yep my bios is upto date already sadly lol
May 30, 2010 1:55:40 AM

well i reinstalled windows and got a benchmark on 3d mark 06 i was wondering what you guys thought I don't have my bookmarks for my others to compare and it looked like same framerate in 3d vantage 06 but who knows??

I thought I posted my benchmarks but cant pull up my threads or find them anyways

3DMark Score 19053 3DMarks
SM 2.0 Score 7081
SM 3.0 Score 10007
CPU Score 4728

Best solution

a c 376 U Graphics card
May 30, 2010 2:14:43 AM
Share

If these numbers are any indication it seems like crossfire is working;
http://www.overclockersclub.com/reviews/sapphire_hd5770...
3DMark can be very dependent on the CPU and settings you are using however.
Like I've said early you would be best off testing in actual games. Just enable crossfire and use fraps, rivatuner or something similar to take a look at the frame rates. Disable it and try again. The difference should be pretty obvious.
May 30, 2010 2:28:30 AM

Best answer selected by cmaki2008.
May 30, 2010 2:28:31 AM

appreciate it bro
May 30, 2010 3:00:32 AM

ya benchmarks don't really show the crossfires working but in the game the fraps if i disable crossfire and then restart the game and load it from a save and do something like run fast in crysis through the same exact spot i can tell a 20+ fps increase lolz I could of saved myself so much heartache if i would of jus tlistened to you as usual.. lol
!