No display after cpu upgrade!! please help me!

yesterday i received a new cpu for my pc (core 2 duo e6600). i used to have a pentium D, i installed the cpu (e6600) and everything correctly and i turned on the pc and the fans spin and everything, but i get no display on my monitor! i cant even reach the BIOS! i cant see completely nothing! then i put back the old cpu (pentium D) and it worked like normal! the pc turned on like it supposed to, i got display!, i only dont get display when i install the e6600 cpu! my motherboard is fully compatible with this cpu! http://www.ecs.com.tw/ECSWebSite/Pro...nuID=1&LanID=0

here is what i have tried:
cleared cmos
checked the powersupply
checked if the cpu was on the slot well put
my video card is not dead! it fully works!
and i also updated my bios to: v1.09, 9/7/2007

all my pc specs i can think of:
power supply: ULTRA 550 watts
motherboard: 945gct-M3
Video Card: nvidia GeForce 9600 GSO
250GB HDD

I CANT AFFORD ANOTHER PC!
6 answers Last reply
More about display upgrade
  1. You bought the CPU from someone? Or is it brand new?
  2. i bought it from someone.
  3. camargo, please do not double post.

    hell_storm, ECS site says mb supports the original Conroe E6600. He undoubtably bought a Wolfdale E6600. A 2007 BIOS will not support it.
  4. it is a conroe (core 2 duo) it supports it.
  5. hell_storm, let's move everything to the other thread:
    http://www.tomshardware.co.uk/forum/279657-12-display-upgrade
  6. jsc said:
    hell_storm, ECS site says mb supports the original Conroe E6600. He undoubtably bought a Wolfdale E6600. A 2007 BIOS will not support it.

    I was just suspecting if the CPU bought was dead already. That's why i asked was it new or bought from someone.
Ask a new question

Read More

CPUs Displays