Sign-in / Sign-up
Your question

5850 very low fps in certain games, please help

Tags:
  • Graphics Cards
  • Games
  • Low FPS
  • Graphics
Last response: in Graphics Cards
May 29, 2010 12:29:57 PM

Hi guys, I have had an issue with my new 5850 for about the past 3 weeks and it has me completely stumped.

Basically I'm getting horrible fps in certain games, particularly older ones. This only started about a week after I had the graphics card installed. I thought the card was faulty at first but it runs very intensive games such as Crysis, Bad Company 2 and Modern Warfare 2 great.

I'm running all my games at their maximum settings with 8xAA, 16xAF and 1920x1080 resolution. Here's a quick rundown of the average fps I'm getting in the games I own.

Bad Company 2 - 55fps
Crysis - 32fps
Modern Warfare 2 - 70fps
Portal - 28fps
Street Fighter IV - 37fps
Resident Evil 5 - 38fps (DX9) (DX10 version seems to run fine)

I've tried reinstalling my drivers and reverting back to older ones but it hasn't made any difference. Any help would be greatly appreciated.

Edit: I forgot to mention that I'm getting 18400 in 3dmark06 which I believe is okay for the 5850 video card.

More about : 5850 low fps games

May 29, 2010 12:51:46 PM

50% of the games I'm playing give me horrible frame rates, that can't be right. My old 9600xt ran Portal better than my 5850 :lol:  Seriously though, could there be some conflict with the drivers? Maybe a format might help?
m
0
l
May 29, 2010 12:58:13 PM

That's kinda weird for Portal. My old 3850 ran portal at over 100fps.
m
0
l
Related resources
May 29, 2010 2:13:00 PM

It's an AMD Phenom II X4 965 @ 3.4ghz. I don't have many games to test but Resident Evil 5, Street Fighter IV, Counter Strike Source, Portal and Battlefield 2 all had <40 fps at the settings I mentioned.
m
0
l
May 30, 2010 6:06:39 AM

No one can help? I guess that only leaves a format and if that doesn't work I'll RMA the card.
m
0
l
a b U Graphics card
May 30, 2010 3:34:00 PM

At the really high resolution you are gaming at your card is performing fine. Different engines are going to have different results with different games. You will even see that happening with a HD5970.

As for the portal thing, yes try reinstalling your drivers and perhaps the game and see what happens?
m
0
l