Sign in with
Sign up | Sign in
Your question

Radeon 5770 issue. Please help me!

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
May 29, 2010 7:34:08 PM

Hi all.

I am running a nforce 720a motherboard with a 2.2gb quad core processor. I wanted to upgrade from the on board graphics and found out that the new nvidea cards canno SLI with hybrid boards. As a result decided to get standalone ATI RADEON 5770 and add some additional memory (2gb to
4gb).
However, following installation pc wont boot.

Fans run, DVD drive spins, HDD reads for a few seconds then stops.

I get no display so I cant try clean install of windows 7.

Please, please help me>8(

More about : radeon 5770 issue

Anonymous
a b U Graphics card
May 29, 2010 7:38:44 PM

@ PsychosaysDi.

Apologies, I didt make it clear. I cant get to the BIOS. I would love to but I just get a black screen whether I take out the new card and try the onboard or reseat the graphics card.

Any ideas?
Anonymous
a b U Graphics card
May 29, 2010 7:45:44 PM

Hi.

Its not laptop although as hybrid I can see why you suggested that.

I unplugged for ages and still the same. Took each compent out and replaced one at a time but still the same.

Should I be getting something on screen even without the HDD connected?

My initial reaction was that something wrong with HDD as makes brief reading noises (2 short then one longer) then stops.

Could the HDD be the issue?

Are ATI cards compatible with nvidea boards?
Related resources
Anonymous
a b U Graphics card
May 29, 2010 7:52:49 PM

also forgot to mention that hdd makes same noise even when sata lead is unplugged as seems to just be hdd boot noise.

Do you think could be issue with sata lead as lead was knocked (very very slightly) when installing (just came out slightly then i pushed back in.
a b U Graphics card
May 29, 2010 7:59:23 PM

Quote:
Hi.

Its not laptop although as hybrid I can see why you suggested that.

I unplugged for ages and still the same. Took each compent out and replaced one at a time but still the same.

Should I be getting something on screen even without the HDD connected?

My initial reaction was that something wrong with HDD as makes brief reading noises (2 short then one longer) then stops.

Could the HDD be the issue?

Are ATI cards compatible with nvidea boards?


He's not thinking it is a laptop -- the battery he is talking about is the CMOS battery (round silver thing) -- It keeps the settings stored when the system is unplugged or turned off and by removing the battery it will clear the settings and reset them to defaults --- also can do the same thing by shortng the CMOS jumper.

Did you plug in the extra power plug on the video card ?? - Are you sure you seated the card into the slot correctly - Does the fan on the Video card start to spin also ?
Anonymous
a b U Graphics card
May 29, 2010 8:09:03 PM

Hi.

Oh brilliant. Ok I like the sound of that answer! I have reset the cmos about 500 times using the jumpers so will try the battery now.........

>8(....nope didnt work.

Yep card seated in PCI 2.0 slot and power cable attached. Card fan spinning away. I have removed card now and trying to get a boot with the onboard grapics but getting exactly the same.

Am I right in thinking the motherboard is ok as all the fans are spinning and the keyboard lights up when power switched on just the HDD doesnt boot far enough and I am getting no display?

I hope you guys can sort this for me as I am loosing the will to live with this one. lol

Anonymous
a b U Graphics card
May 29, 2010 8:45:47 PM

Guys I have been checking for answers in the other threads and used a checklist provided by one of you very helpful tech wizards.


I didnt have the motherboard speaker installed and I installed it and now I get 3 short beeps repeating.

Problem is I dont have the motherboard manual


any ideas?
Anonymous
a b U Graphics card
May 29, 2010 9:07:52 PM

Hi this link mentioned it may be the memory?

the pc was working earlier and then I installed a 2nd 2gb simm. It iss 800mz and I think the other one is 1066. I know it wouldnt be optimal with 2 different speeds but would this destroy my motherboard?

Is there any was to fix this?
Anonymous
a b U Graphics card
May 29, 2010 9:19:23 PM

would new dimm work?
May 30, 2010 3:41:38 AM

it won't destroy just having confused..
ram is really particular "guy" which wants everything his way, so just plug 1066 or 800 because even if it will run windows time to time will crash
May 30, 2010 3:52:58 AM

have you try one memory at the time?
Anonymous
a b U Graphics card
May 30, 2010 8:41:59 AM

Hi.

Yes both Dimms one at a time in all slots.

I am thinking about getting a new mobo. If the board was fried by static when the new stick was installed, would that have affected the original dimm as I dont really want to have to get a new Dimm and a new motherboard - would like the original dimm to work?

I have a feeling that the new stick fried the board and thats why it wont work even with old memory on its own?

The alternative was to get a new Dimm only but I dont want to get a new dimm and risk frying that one? However, would the old original dimm fry the new board?

What do you think the best way forward is?
May 30, 2010 8:47:48 AM

What connector do you use for the monitor? If so swap the cable around between the Graphics Card and Motherboard outputs to check which one is being used. Trust me, an easy mistake to make. (Best mistake I made was thinking I'd destroyed my entire PC by forgetting to plug the motherboard in :p )
Anonymous
a b U Graphics card
May 30, 2010 8:53:31 AM

hiya.

I tried that and have now removed new card and new dimm to try and get a boot from old config.

Still 3 beeps.

I get 3 beeps with no memory at all installed.

Is this normal or does this indicate memory section on board is fried?
May 30, 2010 8:55:26 AM

Hmm, what brand is your Motherboard?
Anonymous
a b U Graphics card
May 30, 2010 8:58:20 AM

Hi.

nforce 720a. Running quad core AMD Phenon 2.2 and 2gb 800 htz (trying to upgrade to 4gb and ati radeon sapphire 5770.
May 30, 2010 9:05:57 AM

I mean what actual make is it, the company who produce it.
!