SATA Drive not Recognised

Hi,

Wondering if anyone might be able to help me with an issue Im having with my MSI AmethystM Micro ATX Mainboard MS-7184.

All of a sudden BIOS no longer sees my Sata Hard drive.

Im currently bypassing the issue by using an IDE/Sata converter which works fine as it thinks the drive is IDE.

Im not sure what might be causing this and afraid to mess about with BIOS updates in fear of bricking my system.

Any info appreciated, thanks in advance, J
12 answers Last reply
More about sata drive recognised
  1. Was it plugged in correctly?
  2. Hi, ya drive is plugged in fine, tried new sata cables and still no good.

    Motherboard has two sata ports and neither is being recognised?
  3. Reset the CMOS. If that doesn't help, try flashing the BIOS.
  4. Thanks for the reply,

    Ive tried resetting the CMOS and I am just after flashing the BIOS.

    It originally had BIOS v3.47 but now Ive upgraded it to v3.9 BIOS for MS-7093/MS-7184 motherboard from MSI website.

    Overall its a much better BIOS setup, more options, less fan noise, but unfortunately still no SATA drives recognised.

    Im still using the IDE/SATA converter but would really like to know whats causing this issue and if it is possible to fix it.

    Any other help appreciated, Thanks again, J
  5. Check the SATA mode is set to IDE.
  6. I cant seem to find this option anywhere?
  7. It would be in the BIOS under something to do with integrated peripherals but it may not have it. One cheap motherboard I had only supported IDE mode.

    Have you tried another SATA drive?
  8. Hi,

    Shortly after making my last post I found that option in BIOS, changed it but still no joy though.

    Ive also updated drivers for ATI SB400 chip and no luck,

    Im running out of ideas.

    Thanks for your help
  9. Have you tried another drive if possible? It could be something with the drive that is causing problems with SATA2 but the converter makes it run in SATA1, for example.
  10. Thanks for reply,

    Ive tried another drive but it doesnt show up either. The board is Sata 1 and so are the drives I tried with it.

    I looks like I wont be able to fix this, would ld I be able to bypass the issue by using a PCI Sata card? Should the card run fine as it has its own independent Sata controllers and chip?

    Something like this:

    http://cgi.ebay.ie/3-PORT-SATA-SERIAL-ATA-1-IDE-VIA-6421A-PCI-CARD-/280580531041?pt=LH_DefaultDomain_3&hash=item4153e72361#ht_2471wt_1139

    Thanks again
  11. Seems like either the motherboard SATA ports have gone, or a problem with the chipset making the SATA ports stop working.

    Yes, a separate SATA controller should work fine. But it may be a good idea to look at a replacement motherboard, and possibly CPU and RAM along with it, instead.
  12. Thanks for your reply, great to get another opinion on this issue,

    Ive been planning on getting another mainboard/cpu/ram etc anyway but hate letting things like this get the better of me, regardless of buying a new system.

    Weird how this happened all of a sudden, Ill get the PCI card and just have to bypass the issue I reckon,

    Thanks again for your help.

    J
Ask a new question

Read More

Motherboards SATA BIOS