Solved

Radeon HD 5850 NOT performing, new system

I just put together my new build this weekend and threw Crysis on it to see how it would handle it. At 1600x900 resolution, 2x AA, everything else on High it runs at an amazing average FPS of 7.2! Something is wrong here. I sent it through a 3DMark Vantage 1.1 preset Performance test to see how it would do and I got an overall score of P13028, GPU of 13975 and CPU of 10853.

- - - - - - -

My specs are:
ASUS EAH5850 Radeon HD 5850
http://www.newegg.com/Product/Product.aspx?Item=N82E16814121375&Tpk=asus%20eah5850

AMD Phenon II X4 955 Black Ed.
http://www.newegg.com/Product/Product.aspx?Item=N82E16819103808&cm_re=955_black_edition-_-19-103-808-_-Product

G.Skill Ripjaw DDR3 SDRAM DDR3 1600
http://www.newegg.com/Product/Product.aspx?Item=N82E16820231303

ASUS Xonar Essence STX
http://www.newegg.com/Product/Product.aspx?Item=N82E16829132010&Tpk=asus%20xonar%20stx

MSI 890FXA-GD70 AM3 AMD 890FX
http://www.newegg.com/Product/Product.aspx?Item=N82E16813130274

Antec TruePower 750W
http://www.newegg.com/Product/Product.aspx?Item=N82E16817371022

I'm running it on Windows 7 Professional 64-bit

- - - - - - -

The GPU is idling at 33 Celcius, the CPU is idling at 29 Celcius
Under load the GPU stays around 58 Celcius and the CPU at 46 Celcius

I installed all the most recent 64-bit drivers for everything, double checked power supply connections, made sure CCC was letting the application decide the settings and made sure I was running the 64-bit Crysis executable, I have no clue what I could have done wrong to cause such poor performance.

Thanks for any help or advice.
7 answers Last reply Best Answer
More about radeon 5850 performing system
  1. I don't know why, but this seems like the GPU is underclocked.. Try running the 32-bit Crysis.exe
  2. Running it from the 32-bit executable worked, now it runs around 35-40 FPS with 1600x900 res with 2x anti-aliasing on High. Huh, why did it perform so terrible with the 64-bit exe? Thanks for the help.
  3. 64-bit uses more ram, and is supposed to help it run better, but if you don't have enough ram to support it, it actually decreases performance... I think.
  4. I did some research, apparently there are some tricky installation tricks you need to perform to get the 64 bit version of the game to run well. That's a relief, I was really freaking out there for a second.
  5. Best answer
    seanr111 said:
    Running it from the 32-bit executable worked, now it runs around 35-40 FPS with 1600x900 res with 2x anti-aliasing on High. Huh, why did it perform so terrible with the 64-bit exe? Thanks for the help.


    I think your GPU might still be underperforming. I have a XFX 5850 and get ~35-40fps at 1920x1080p with settings on high and AA at x4.

    According to Toms, a 5850 at very high and 1920x1080 w/ 0 AA gets ~30fps, and with AAx8 gets ~27 fps. http://www.tomshardware.com/reviews/radeon-hd-5850,2433-6.html

    See in GPU-Z if your card is running at max speed during games. Also, make sure you have the latest GPU drivers, no Nvidia drivers whatsoever.
  6. Good idea, I'll make sure I check that. So I'm guessing if it was underpowered I could fix that with tweeking instead of sending it back as a defect?
  7. Best answer selected by seanr111.
Ask a new question

Read More

Graphics Cards Graphics Product