Sign in with
Sign up | Sign in
Your question

Ubuntu/Win7 Dual boot - Diskpart shows Ubuntu disk but no volume.

Last response: in Storage
Share
September 7, 2012 7:04:53 PM

I have two SSDs, one has Ubuntu on it and one has Windows 7, which I installed today.

During the setup I had an error which prevented me installing to the hard drive, which I fixed by disconnecting my Ubuntu SSD then installing - which worked.

However, Windows overwrote my Ubuntu UEFI entry or something, and now I can only boot into Ubuntu by pressing F8 in Asus' UEFI and selecting the SSD, which is annoying since I have to hit delete to get into UEFI every time I want to use Ubuntu (I'll only use Windows for gaming, and Ubuntu's my main OS), which is every boot.

When I try editing the boot order in UEFI, it boots into Windows anyway, so I hoped I could add a bcdedit entry for Ubuntu, but alas the Ubuntu hard drive doesn't have a disk letter so I can't add an entry for it. When I use diskpart I can list the Ubuntu disk fine but it doesn't show up in the listed volumes, so I can't assign a letter - Also, in Disk Management it shows up, but the only option that isn't greyed out for the Ubuntu SSD is "Delete volume".

I'd like to know if there's any possibility of being able to create a volume for the Ubuntu SSD (Disk 0 on Diskpart) so that I can add it to Windows Boot Manager via bcdedit. If not, I'll just have to hit delete every boot and boot into my Ubuntu SSD manually.

Thanks in advance.
a b G Storage
September 8, 2012 9:19:28 PM

insert both drives into the computer how u like 'em

download linux live usb creator @ http://www.linuxliveusb.com/en/download

follow steps 1 ~ 3 to make you linux ISO bootable from USB

boot the computer using this Live USB. in the boot menu, select Live Mode (or persistent mode if you made one)

open a konsole or bash window

type: grub-install /dev/hda

(this will install the Grub bootloader onto the first bootable disk. with grub installed you will be presented with the option of windows or linux on boot.)
!