Sign in with
Sign up | Sign in
Your question
Closed

The trust relationship between this workstation and the primary domain failed er

Last response: in Windows 7
Share
a b $ Windows 7
November 2, 2011 3:52:31 AM

Relationship issues are fun!!

When you try to access a computer running Windows NT Server or Workstation that is a member of your domain with one of the following method, and it fails... it will show this message:

System Error 1789 has occurred. The trust relationship between this workstation and the primary domain failed.

Cause:

The computer's machine account has the incorrect role or its password has become mismatched with that of the domain database.

Fix:

Log on locally as a local administrator (If you can). In the Network tool of Control Panel, select Change and enter a Workgroup name, leaving the domain. Restart the computer and log on locally as a local administrator.

Or

You can delete the existing computer account in Server Manager, recreate the computer account, synchronize the domain, and then on the client rejoin the domain.
Score
0
November 2, 2011 4:14:16 AM

I've struck this issue a few times, always with Windows 7 clients and Server 2003.
If you can't log in locally try logging in as a domain administrator with the network disconnected (unplug LAN and disable wireless), this will allow the use of cached credentials.

Once your in ..
Reset the local administrator password
log off and on as the local administrator to test it
Disjoin the domain (change to a workgroup member instead)
Restart as prompted
Log in as the local administrator
Rejoin the domain
Score
0
Related resources
a b $ Windows 7
November 2, 2011 9:14:01 PM

hmmm... and that didn't work this time?
Score
0
August 14, 2012 12:59:43 PM

If you get stuck while working on workstation on your computer and giving annoying error error message then your should first remove the your antivirus software which may gives you such rogue activity. In order to safely remove such infection you can use an automatic spyware removal tool. which easily remove this infection and protect your PC from further corruptions. You can also use this application to remove the Windows Secure Workstation virus easily using this automatic removal tool.

For more information visit: http://www.adwareremovalprograms.net/easily-uninstall-f...
Score
0
June 3, 2013 3:13:30 PM

This works. We get this error sometimes when a password change occurs.
Score
0
a b $ Windows 7
June 11, 2013 5:31:02 AM

I get this a lot in a friends company he runs.

We figured that the only way to fix it permanently. Is to get the pc off the network by removing it from domain via system properties having it as a workgroup instead.

Then going into A.D. finding the pc deleting it from A.D.
Restart the pc
Re-add the pc to the domain.
Score
0
July 25, 2013 2:09:58 PM

I had this issue with a Windows Server 2012 180 eval acting as the AD Primary for a Windows 7 client. These are the steps I just followed a few minutes ago to alleviate the issue.

1) I logged into the AD, went into the AD Domains and Trusts area.
2) Found the domain, right clicked and went to manage.
3) Found the machine in question under the "Computers" tab, right clicked, and "Reset Account".
4) Tried logging in the user on the client machine in question.

Upon attempting to login from the client it was successful. The login took about 2 minutes to complete so it must have been reconnecting the "relationship".

-TMinus36
Score
0
January 14, 2014 10:28:30 AM

In my situation, the PC's account was disabled. I right clicked the PC in AD and selected 'Enable Account'. Easy!
Score
0
April 8, 2014 10:00:27 AM

Freakykiwi said:
I've struck this issue a few times, always with Windows 7 clients and Server 2003.
If you can't log in locally try logging in as a domain administrator with the network disconnected (unplug LAN and disable wireless), this will allow the use of cached credentials.

Once your in ..
Reset the local administrator password
log off and on as the local administrator to test it
Disjoin the domain (change to a workgroup member instead)
Restart as prompted
Log in as the local administrator
Rejoin the domain


Freakykiwi: You are a freaking genius. This was simple and painless. Thank you very much!
Score
0
!