Sign in with
Sign up | Sign in
Your question

2TB HD shows up in Device Manager but not Explorer

Last response: in Storage
Share
September 9, 2012 9:07:30 PM

My external hard drive recently stopped showing up in Explorer. Long story short, I took it out of its enclosure and connected via SATA. It's still doing the same thing: it shows up in Disk Management as online and healthy, but without a drive letter or the ability to assign one. I've tried connecting it to a different motherboard, but that hasn't worked either. The drive in question is/was a Seagate GoFlex 2TB.




Is there anything I can do, aside from reformatting? Both of my back up drives failed within two days of each other, so this is all I have left. I accept that ultimately, reformatting may be my only solution, but I hoping that there's some other option out there.

Any advice is greatly appreciated. Thanks in advance!
a c 104 G Storage
September 9, 2012 10:33:59 PM

Hello,

The reason this partition is not recognized by Windows Explorer is that it has no drive letter assigned to it (that's obvious). It is very unusual to have the C: drive on a different Hard Drive than the EFI reserved hidden partition (200MB) but your Disk2 has the system & boot volume on it. Did you specifically put the boot drive on Disk 2? My guess is that the 1.8GB partition on Disk0 was the original C: drive and the drive letter conlicts with the C: label on Drive2.

Problem is I don't think you can actively temporarily change the Disk2 C: label to see if the Disk0 letter reappears.

You might try the cmd line DiskPart program to force a drive letter on the Disk0 partition
Start the cmd program, the DiskPart in the system 32 directory.
DiskPart> List Volume> Select Volume. Select the volume you want to work on (1.8GB volume)
DiskPart> Assign letter = "a drive letter". That may force a new Drive letter on this partition, which you could then change to whatever you want in Disk Management.

There are directionis in the help section ? as to how use this low level program, which can be cryptic and unforgiving.

Do you have any valuable data on this 1.8GB partition? As a last resort you could delete the partition, which would give you a large space that would be Unallocated. You could then create a new partition from this space and make it any size you want.



m
0
l
a b G Storage
September 10, 2012 12:10:56 AM

According to your screenshots, Windows is not recognizing your external drive's 2TB partition as an NTFS partition. Windows has no provisions for mounting non-NTFS and non-FAT partitions, so the only option it is giving you is to delete the partition (don't delete it).

You need to figure out what's wrong and possibly repair the partition table. You said you removed the drive from its enclosure? Did the problem occur before or after you removed it? It's possible the enclosure was doing something funny at the SATA-USB interface, causing it to work from within the enclosure but stop working when taken out. If this is the case, all you have to do is put the drive back in the enclosure and it should work again.

If it didn't work in the enclosure, then my guess would be a damaged partition table. The good news is that (provided you haven't deleted anything or changed any configuration on the drive) your data is probably safe. Fixing this could be as simple as using a partition table editor and reflagging the 2TB primary partition as NTFS. Or it could be a much more complicated. It all depends on what's damaged on the partition table.

If the data is valuable, I'd suggest not messing with the drive. Buy another 2TB drive and do a raw image copy of the old drive to the new one. (This should take less than half a day with all drives mounted internally - 2TB / 50 MB/s = 11.1 hours. If it takes significantly longer, your drive is probably failing). I'm more familiar with Unix tools, but I believe Partition Wizard's disk copy function will do this.
http://www.partitionwizard.com/free-partition-manager.h...

Once it's copied, put the original drive in a safe place. Then you can go nuts trying to fix the new drive (copy). If you screw up, you can always make another copy.

I'd rather not go into the details of fixing your partition table until we can confirm that that's actually the problem. But if you wish to go ahead and try on your own, the Ultimate Boot CD has several partition table editing tools. Since you have no backups, I will reiterate that it's very dangerous to use these tools on the problem drive. You could make it completely unrecoverable. Copy it to another drive first, then mess around with the copy drive.
http://www.ultimatebootcd.com/
m
0
l
Related resources
a c 288 G Storage
September 10, 2012 8:27:21 AM

@daysspentapart, the reason that your GoFlex drive doesn't show up in Explorer when connected internally is that GoFlex external enclosures use 4KB LBAs. When you remove the drive and install it inside your PC, the drive's own 512-byte LBAs are exposed. This means that the Windows will see your file system as jibberish. You must reinstall the drive in its enclosure, otherwise you will just make the problem a lot worse.

m
0
l
September 17, 2012 1:45:22 AM

Thanks for all of the replies! I ended up using data recovery software to retrieve the files I needed from my drive. Since then, I've reformatted, and everything's been running well. Thanks again!
m
0
l
!