Solved

Catalyst 10.5

Hey guys, I've recently downloaded ATI Catalyst 10.5 onto my Alienware Aurora, and whenever I click on it to open, it doesn't open? It shows a load button and stops. Any ideas?
8 answers Last reply Best Answer
More about catalyst
  1. Do you mean the downloaded file does not open or the CCC does not open after you installed it ?

    What OS and what hardware ?

    If the downloaded file does not open, it could be a bad download "File corrupt". Please try another download.
  2. I downloaded it about 3-4 times already, and even tried 10.4 When you right click on your desktop, it usually shows ATI Catalyst, and when I click to open it it doesn't open. OS = windows 7 hardware = ATI radeon hd 5870, i5-750, 4gb dual channel ram, 500 gb 7200rpm HDD, 22x dual layer dvd/cd rom.
  3. try uninstalling everything ATI, reboot, run a registry cleaner and then reinstall.
  4. BTW, comp is brand new
  5. Your computer may be in need of .exe file fix. Please see: http://support.microsoft.com/kb/950505/

    Hope this helps.
  6. Best answer
    dude i had the EXACT same problem as you do (but with 10.4). I even have the alienware aurora---brand new! haha

    so to solve this, then i went to the control panel, uninstall a program, then i uninstalled/removed the catalyst install manager. then i installed the 10.4 CCC, restarted and presto! actually, you may have to restart after removing the install manager but i can't remember.

    i looked high and low to solve that and found that people have been bumping into this problem since like CCC 9.x and that's how they got through the problem!
  7. Okay guys, finally solved it. Seems like I needed 2 reboot after installation and now everythings worknig fine TY!
  8. Best answer selected by virrze.
Ask a new question

Read More

Radeon Alienware Catalyst ATI Graphics