Sign in with
Sign up | Sign in
Your question

PC Not Detecting Internal HDDs

Last response: in Motherboards
Share
April 14, 2011 5:58:18 PM

Hi, I have been having a problem for the last two or three weeks where my PC will Bluescreen or just freeze up, and when I reboot I get one of a few issues:

1) Overclocking has Failed! Press F1 to enter setup blah blah..

When this occurs I just enter setup and leave it and my PC boots fine, unless it runs into issue #2.

2) Computer POSTs fine, when it get to the AHCI Drive Init. it detects my DVD Drive, but sits thinking trying to access the 2 HDDs there. Eventually it gives up and continues, displays it found my eSATA External HDD, and tries to boot from my DVD Rom...Please insert boot media and press any key or reboot.

When this happens I check everything, I tried to run an HDFT but it doesn't find the drives, if I rescan the bus it hangs trying to find the two drives and eventually just gives up.

Every once and a while it reboots and I can finally get into Windows. As is now. I don't know what to try.

Some information on my Rig:

Proc.: AMD Phenom II 1090T

Name AMD Phenom II X6 1090T
Codename Thuban
Specification AMD Phenom(tm) II X6 1090T Processor
Package Socket AM3 (938)
CPUID F.A.0
Extended CPUID 10.A
Core Stepping PH-E0
Technology 45 nm
TDP Limit 130 Watts
Core Speed 3724.4 MHz
Multiplier x FSB 16.0 x 232.8 MHz
HT Link speed 2095.0 MHz
Stock frequency 3200 MHz

(I just used ASUS's OC Utility, i'm not a big Overclocker so I just went with whatever it spit out and have been stable and cool)

RAM: 8GB DDR3 GSkill Ripjaws 1600
MOBO: ASUS M4A87TD EVO

HDDs: Western Digital Caviar Blue WD6400AAKS 640GB 7200 RPM 16MB Cache SATA 3.0Gb/s 3.5" (x2, not in raid and one isn't even being used, but still doesn't get recognized)

The HDDs are old, oldest thing in the rig next to the PSU and DVDRW.

a b Ĉ ASUS
a b V Motherboard
April 14, 2011 8:13:59 PM

Are both your HDs boot drives? If you halt POST and go into BIOS, do the HDs show up there?
Forget the OC, just run at default settings and see how it runs.
Could be a corrupted BIOS -clear CMOS and reflash.
Bad cables to HDs - buy new cables
Windows might be corrupted - do a repair from OEM disc

April 14, 2011 8:45:45 PM

No, only one drive is a boot drive the second drive is literally nothing, it has nothing on it, but when the error occurs and its POSTing and trying to Init. the AHCI drives theres a faint click...click...click... from the drives. This occurs with either drive (as in if I take one or the other out it happens to both).

If I set the ATA Controller to IDE Mode the HDDs are not listed. When it's in AHCI mode it doesn't list the dives anywhere in the BIOS (except in the boot order) which it still has the drive there, but when you get out of it they are not detected during the AHCI Drive Init. In any case during this issue if I pound F8 to get a list of boot devices the HDDs don't show up on that list no matter what.

Default settings do the same thing, when the error occurs I have tried to "load setup defaults" and it keeps up with it's issues. Only reason I've kind of ruled out the OC is that when I ran the OC Utility a few times after getting nowhere with the default setup I've made it into Windows.

I have swapped every port-cable combination imaginable with a cable I KNOW works (the one connected to the DVD - RW), and a new one I had as a backup.

Windows COULD be corrupted I suppose but if it GETS to Windows there is rarely an issue, when I get a bluescreen though they are few and far between. I shot a picture of one because i'm usually not there to see them, or they pass too quick but the STOP Message is 0xF4 the first param. being 0X3. Which is a process is stopped.

This is an intermittent issue, as in it happens every day, now that I've wasted my day on it, it is going to be fine until tomorrow most likely, pretty much once you get into windows, the machine is fine.
Related resources
a b Ĉ ASUS
a b V Motherboard
April 14, 2011 10:17:17 PM

Well, the clicking usually indicates a failed write-head in the HD. It would be incredibly unlikely for both drives to fail simultaneously, assuming no voltage spike from the PSU.
That said; you could enable (if your BIOS has the setting) S.M.A.R.T. in your BIOS, download Speedfan, and it will give you a reading on your HDs health.
a c 207 Ĉ ASUS
a c 715 V Motherboard
April 14, 2011 10:50:00 PM

IMO, shutdown and pull the SATA cords {incl eSATA} from the MOBO - all except the Primary HDD with the OS. Boot to the BIOS, Load Defaults, save and exit.

The Primary is best suited in the FIRST SATA {SB850} Port.

Assuming your boot into Windows, chances are changing the IDE <-> AHCI corrupted Windows. Also, assuming Windows 7; choices manually change the registry or run Fix It -> http://support.microsoft.com/kb/922976

Next, uninstall ANY ASUS Utility {all OC utilities are an accident waiting to happen}, next reboot.

If you cannot boot into Windows then assuming again W7 insert the Windows DVD, connect the DVD and keep hitting 'F8' until the recovery is available. See -> http://windows.microsoft.com/en-US/windows7/What-are-th... Choose Startup Repair.

After all of that funness, boot into the BIOS and change the SATA {SB850} -> AHCI and repeat the 'Fix It' procedure above. Reboot to test.

After you're running, next add the DVD, reboot. Then repeat until all drives are up and running.
April 15, 2011 5:24:27 AM

I agree that the "clicking" sound coming from a hard drive usually means a hardware failure. It's possible that the drive was damaged if the computer was moved, even an inch, while it was turned on. Newer drives seem even more prone to damage as their tolerances have tightened and their data density has increased.
a c 207 Ĉ ASUS
a c 715 V Motherboard
April 15, 2011 2:24:53 PM

Clicking can mean a whole lot of things, and typically a failed HDD sounds more like 'scratching'. The clicking typically means the sector(s) have garbage/corrupted data that the HDD repeatably is trying to access. Changing IDE <-> AHCI will corrupt data.

If the OP can get the HDD to read then do theses options -> http://i1013.photobucket.com/albums/af254/Jaquith/Scan-...

If the corruption is sever then set up the BIOS correctly as desired e.g. AHCI, backup the data, and reformat e.g. start from scratch.
April 17, 2011 10:22:49 PM

First off, I would like to thank all the people who replied, I appreciate the troubleshooting tips. Thank you!

CHKDSK on my main drive did not complete. Well it got to 5 of 5 complete and just sat there for 2 hours.

I used HDFT and cleared all my drives for use.

The ASUS OC Utility I used can't be uninstalled, it's part of the BIOS.

On the last and final hand it put the drives all into IDE mode. This almost works. If I pop in the HDFT boot CD and run it and it ALSO doesn't find the drives, I just force it to rescan the bus 1-4 times (usually one 1) and once it finds them just reboot and I get into windows.

The bluescreens started to bother me more, so I downloaded a new memtest and got massive errors. I'm in the process of sending my RAM back to GSkill. The question is could the RAM cause this issue?

The clicking btw is VERY controlled, and synchronous. So I don't think theres anything wrong with the drives. If I were to guess it'd be that they're trying to be read in the same spot but something is hanging it up (possibly the RAM?) but the drives seem fine.
a c 207 Ĉ ASUS
a c 715 V Motherboard
April 17, 2011 11:09:03 PM

No, what I am/was referring to are BIOS invasive crapware 'ASUS OC Utilities' like ASUS AI Suite, AMD OverDrive Utility, or anything that screws with the BIOS via an OS other than that 'read' values and that 'can be uninstalled'. The BIOS built-in OC Tuner Utility is almost as bad a choice.

If you try the RAM again, correct slots, with BIOS: Load Defaults and then you're getting Memtest errors that's a whole different thing.

If your RAM was improperly set in the BIOS then yep you'll get untold number of errors and write garbage to the HDD. Getting errors with the proper DIMMs and BIOS 'Defaults' is unacceptable and default 'SPD'. However, if you getting into the BIOS like a blind-man riding a bull in a China Shop then it's very easy to create a unstable environment and have anything failing.

You skipped from 'bad HDD' to 'bad RAM'....

Good Luck! :) 
April 17, 2011 11:45:09 PM

Yah definitely. Well I saw what the OC Tuner Utility did, and it never touched voltages past recommended setups from what I saw on the net (in fact it was quite mild and and kept me very stable).

Generally speaking I know what I'm doing in BIOS, so I never touched my RAM's voltage and kept the timings and clock at their standard settings. They are set properly, and it looks like GSkill agrees that the sticks are just shot.

But my ram was set up by It's defaults, the only thing the OC Utility in bios did was actually underclock the RAM to 1333, and all I did was set it back to 1600, which is it's standard. Everything else was set to the SPD settings.

My Memtest results are under "Default settings" on my BIOS, so yah, probably my RAM, lets just see if it clears it all up when they get replaced.
a c 207 Ĉ ASUS
a c 715 V Motherboard
April 18, 2011 12:16:00 AM

Here's a possible problem(s) "and all I did was set it back to 1600"

1. At 'SPD' it's 1.50v and at Rated it might be 1.65v
2. At 'SPD' its CAS might be 8-8-8... and at Rated it might be 9-9-9

Q - What exact Ripjaws? {need link}
Q - Other than AHCI, what else are you trying to do? e.g. OC?
!