Sign in with
Sign up | Sign in
Your question
Closed

AHCI bios settings

Last response: in Motherboards
Share
April 15, 2011 5:22:41 AM

I'm really confused as to whether I have AHCI enabled already and what I need to change if its not.


Just to avoid confusion the paths are in the format "Sub Menu>Option Name [Options Available]", they are all in "Integrated Peripherals" Main menu.

"Extra Raid/IDE controller [Enable/Disable]" is enabled.
Only avail with extra controller enabled- "Raid Mode [IDE]" (Only that one option.)
"On-Chip ATA Devices>PCI IDE Busmaster [Enable/Disable]" is enabled.
"On-Chip ATA Devices>On-hip SATA Controller [Enable/Disable]" is enabled.
"On-Chip ATA Devices>RAID Mode [IDE/RAID/AHCI]"
I have tried it with both IDE and AHCI, and this is confusing me the most. With IDE, in the boot priority selection it shows "SATA: Hard Drive Name", but with AHCI it shows "IDE: Hard Drive Name.

More about : ahci bios settings

Best solution

a b V Motherboard
April 15, 2011 12:53:39 PM

First, ACPI has nothing to do with AHCI. ACPI is a power management spec, while AHCI is a disk mode.

Your disk mode for your SATA devices is set to RAID. If it is, even if you don't have a RAID array defined on your SATA controllers, with it set to RAID, your individual disks will run in AHCI mode.

Your "Extra Raid/IDE" controller seems to be what enables your legacy IDE controller and its connection (the black connection next to the white SATA connections on your motherboard that uses big gray ribbon cable with the thin red stripe on the side) on your motherboard. There is only one option when for RAID on this type of controller: IDE.

I'd say you're already running in AHCI mode if you're only using SATA connections (white connector off the motherboard) to SATA disks given that your On-chip ATA devices setting is set to "RAID Mode".
Share
April 15, 2011 1:38:15 PM

ubercake said:
First, ACPI has nothing to do with AHCI. ACPI is a power management spec, while AHCI is a disk mode.

Your disk mode for your SATA devices is set to RAID. If it is, even if you don't have a RAID array defined on your SATA controllers, with it set to RAID, your individual disks will run in AHCI mode.

Your "Extra Raid/IDE" controller seems to be what enables your legacy IDE controller and its connection (the black connection next to the white SATA connections on your motherboard that uses big gray ribbon cable with the thin red stripe on the side) on your motherboard. There is only one option when for RAID on this type of controller: IDE.

I'd say you're already running in AHCI mode if you're only using SATA connections (white connector off the motherboard) to SATA disks given that your On-chip ATA devices setting is set to "RAID Mode".

If I enable raid it will disable trim on my SSD though. I am using all sata 3 connections, but any clue why it would label them as IDE when they are running in AHCI?
Score
0
Related resources
April 15, 2011 1:43:35 PM

Best answer selected by Nakkiel.
Score
0
a b V Motherboard
April 15, 2011 2:59:00 PM

Nakkiel said:
Its definately running as AHCI, found a post that shows where to check. (Device manager) If anyone knows why it says in boot list IDE I'm still curious though. >.>

http://www.tomshardware.com/forum/257844-32-ahci-enable...

During the POST it checks each of your disk controllers for a possible boot device. You have two disk controllers (SATA and "Extra IDE). It's seeing your enabled IDE controller. You can disable the "Extra Raid/IDE" controller. That should remove it from the boot list altogether.
Score
0
April 15, 2011 6:42:37 PM

ubercake said:
During the POST it checks each of your disk controllers for a possible boot device. You have two disk controllers (SATA and "Extra IDE). It's seeing your enabled IDE controller. You can disable the "Extra Raid/IDE" controller. That should remove it from the boot list altogether.

Nope, I tried disabling that and it still says IDE. Also, if that were the case it would only show my CD drive as IDE, but it shows all of them.
Score
0
a b V Motherboard
April 15, 2011 7:28:49 PM

Nakkiel said:
Nope, I tried disabling that and it still says IDE. Also, if that were the case it would only show my CD drive as IDE, but it shows all of them.

Can you take this out of the boot sequence under boot options in the BIOS?
Score
0
April 16, 2011 12:14:48 AM

ubercake said:
Can you take this out of the boot sequence under boot options in the BIOS?

The label? No. It just shows up on the name of each drive except the CD and USB if I have one in.
Score
0
a b V Motherboard
February 3, 2012 10:13:05 PM

This topic has been closed by Mousemonkey
Score
0
!