New PC doesn't boot

Hi
The specs are:
i7 930 CPU
Intex DX58SO MB
3x2Gb G.Skill F3-10666CL7T-6GBPK RAM
Sapphire Vapor-X 5770 1Gb GPU
Antec Neo Eco 620W PSU
Samsung 500Gb HDD
Antec Three Hundred case

Fans work, the HDD spins, but no POST or Display signal. Unplugged everything, plugged back one by one, unplugged and tried it outside of the case...nothing. Read the sticky, did everything again, still no use.
After that went to a friend and managed to get into BIOS with his i7 920 CPU (put mine in his comp - no signal).
Is there a possibility that something other than the CPU is faulty? Replacing it is going to take awhile, so I want to be sure beforehand.
Thanks
9 answers Last reply
More about doesn boot
  1. ^ Well if you have followed the sticky properly and no signal with your CPU in his computer, then it must probably be a bad CPU...
    But again go through every step in that sticky if you have not gone through all the steps...
  2. out of curiosity did you take out the RAM and try booting and see if you get beep codes? (test for faulty mobo)

    Also make sure CPU and heat sink are on secure

    Also try diff video card and diff RAM if can get or have extra just to see
  3. k3y3n1n said:
    out of curiosity did you take out the RAM and try booting and see if you get beep codes? (test for faulty mobo)

    Also make sure CPU and heat sink are on secure

    Also try diff video card and diff RAM if can get or have extra just to see


    Did everything once more, MB doesn't beep without memory. Tried another GPU (Nvidia 240 or something like that)- same results.
  4. Do you have a case speaker hooked up? No beeps without one.
  5. There's a built-in speaker on the MB
  6. I miss read your top post, You should try all your eqp in your friends computer minus the CPU bc you did that already and for even more testing have his cpu in your mobo and test your parts again make sure everything works and then RMA the cpu because i didn't see that line you said you put your cpu in and it failed sorry
  7. k3y3n1n said:
    I miss read your top post, You should try all your eqp in your friends computer minus the CPU bc you did that already and for even more testing have his cpu in your mobo and test your parts again make sure everything works and then RMA the cpu because i didn't see that line you said you put your cpu in and it failed sorry


    Gonna take the comp to a lab test tomorrow, don't want to risk frying some of his equipment :)
  8. k0syak said:
    Gonna take the comp to a lab test tomorrow, don't want to risk frying some of his equipment :)



    Ya well if you are using the 930 and he is using the 920 no big diff just your CPU is OC a lil more that's all. But better be safe than sorry good luck
  9. k3y3n1n said:
    Ya well if you are using the 930 and he is using the 920 no big diff just your CPU is OC a lil more that's all. But better be safe than sorry good luck


    Thanks!
Ask a new question

Read More

New Build Intel i7 Systems