Sign in with
Sign up | Sign in
Your question
Solved

Windows Delayed Write Failed

Last response: in Storage
Share
September 14, 2012 6:38:45 AM

Ok, i researched all forums regarding this topic here, but it seems mine is a bit more unique. Hence i am posting a new thread in a quest for answers.
Recently i added a new WD Caviar Green 500GB internal hard drive to my exisiting 80GB WD internal drive on my Desktop. I have freshly installed Windows XP SP3. I had a backup of all data in a separate laptop, before the Windows Installation, and now i am putting them back into the Desktop. However, i am facing a problem with the new hard disk.
Every copy into the old hard drive partitions happen fine. But any copy into the new hard drive takes way longer than usual, system slows down heavily, and i get consistent pop-ups that "Windows Delayed write failed" for each file being copied.
I googled for some answers and have done quite a bit of diagnostics myself - much to no avail. Can anybody tell me what seems to be the problem and how to solve it?
Listed below is all that i have done so far -
The new 500GB has 2 partitions - 200 & 265GB. The older hard drive has 2 partitions - System partition 20GB & another of 55GB.
1) The problem is not only with USB transfers , since file transfer between partitions (older to newer) also result in the same problem.
Interestingly, only "Copy" to newer hard drive partition results in such a problem. But if i move a file from the newer hard drive to the older drive partitions, there seems to be no problem.
2) Increased page table entries by increasing the value of the registry key HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/SessionManager/MemoryManagement/SystemPages - to BFFF.
3) I am not using RAID arrays.
4) My BIOS has no setting for faster UMDA - Crosscheck if you may - Motherboard Intel D946GZIS and Intel Core 2 Duo E6300 1.86Ghz.
5) LargeSystenCache registry key is still 0 by default.
6) Write Caching on Disk is disabled.
7) Ran Diagnostic tools from Western Digital Support to check for bad sectors on my hard drive - it says all is fine.
8) All drivers and BIOS is upto date.
I desperately need help!!
September 14, 2012 7:04:29 PM

Thanks for the input - but yes, chipset drivers are also updated. The RST technology does not apply to my chipset - Intel 946 family :-)
Anything else that i can try?
m
0
l
Related resources

Best solution

a c 86 G Storage
September 14, 2012 7:50:01 PM

Change the SATA cable and port?
Share
September 14, 2012 11:10:28 PM

On My Computer, right click the drive and go to Properties > Tools > error checking > check off both boxes. See if that picks up anything that the WD tool did not.
m
0
l
September 15, 2012 7:31:33 AM

Aaah! I hate it when so much of research and problem get solved with such a small solution!! Cables it is! I changed the SATA cables and the port... and it has been working fine ever since!
Thank you all for the help and the inputs!!
m
0
l
September 15, 2012 7:32:09 AM

Best answer selected by Manoranjan2012.
m
0
l
April 29, 2013 9:33:18 AM

noidea_77 said:
Change the SATA cable and port?


Your answer saved me yesterday.My torrent clients were freezing (no kbd/mouse input) on starting. I formatted OS,Installed kaspersky, talked ISP cc ppl but no effect.Last night when i was moving some file from torrent HDD to the main one I got this "Windows Delayed Write Failed". Came to your solution.Applied it and SOLVED. thank you and OP.
m
0
l
!