Sign in with
Sign up | Sign in
Your question

A7V - Win2k - reboot is corrupting registry

Tags:
Last response: in Windows 2000/NT
Share
December 14, 2000 5:51:37 AM

I am running Win2k with an Asus A7V with Thunderbird 850MHz, Asus Geforce256 Deluxe(6600), 192M RAM, Soundblaster Live, Maxtor 20Gb ATA100 harddisk with 2Mb cache... I am not overclocking yet... haven't gotten to that stage yet.

I have tried just about everything, currently loaded the latest drivers from VIA (4in1 ver.4.26), latest BIOS 1.005a, even disabled the Promise ATA100 controller.

The machine runs pretty smoothly and is stable finally, 3DMark2000 runs fine, but with a pretty low score of 3561...

However, if I reboot the machine with start-shutdown-(reboot or shutdown), my registry has a 80% chance of being corrupted on the next logon... I can recover it from the last backup with the console repair function, however, it shouldn't happen. On shutdown I do notice harddisk activity even upto the machine rebooting... i.e. I think Windows may not give the harddisk enough time to finish what it's writing...

I know others have posted this problem as well in other forums, but I haven't seen a solution to it... Did anybody solve this problem ? I have even spoken to Microsoft, but they don't seem to have this on file either...

If I do a "log off" first, and then choose reboot from the logon menu, I haven't noticed a crash yet... However certain updates want to reboot the machine while I am logged in, and there seems no way around it...

Any advise appreciated.
Anonymous
December 14, 2000 3:55:37 PM

Hi:

Just check the Asus site for the BIOS you mentioned, the latest one I seen was 1004d.
ftp://ftp.asus.com.tw/pub/ASUS/mb/socka/kt133/a7v/

I've setup two of these mb with the Athlon 1GHz and an Duron 800Mhz just recently. The Althon system I had problems with the Asus 7700 GeForce 256 GTS at 4x clock and the OpenGL using 3D Modeling programs, we tried two different boards the last one with Samsung DDRs which seemed
better but not perfect. In the end we set 2X with the Performance setting in the BIOS, which provide stable viewing of the 3D images, called that good enough.

Phil
Anonymous
December 14, 2000 4:05:18 PM

Hi:

During the installation did you install the Promise Ultra ATA100 driver, then move the ATA100 cable to the Primary ATA100 IDE conector?

There is a Promise Ultra ATA100 driver on the Asus web site as well.

http://www.asus.com.tw/products/motherboard/socketa/a7v...

I have the Asus Support CD-ROM 7.08 and I don't see the 4 in 1 drivers listed in the menu, not sure how you installed them, these are mainly VxD intented for the Win9x products.

Phil
Related resources
December 14, 2000 11:50:23 PM

Hi,

I have loaded all the latest drivers... VIA 4 in 1 version 4.26, Via AGP 4.04, promise drivers build 33...

I hasn't happened for the last 2 days, but I guess it's because I don't shutdown before log-off... and really give the PC time before shutting down, but I shouldn't have to worry about this...
December 14, 2000 11:55:28 PM

Hi Phil,

The latest Bios 1005a is on the german asus web-site... www.asuscom.de. It's more stable than 1004d...

I don't have a problem with the AGP... My problem is that when I shut down without logging off first, my registry gets corrupted.. a completely different problem... ~help~
Anonymous
December 15, 2000 12:03:11 AM

I can't find the URL, but there is a VIA/AGP patch available from Microsoft that may help you here.
Perhaps someone has a link they can post for you.

Good Luck
December 15, 2000 12:07:07 AM

Hi,

The Microsoft patch doesn't really help as it replaces viaagp.sys, which is no longer loaded... Win2k loads viaagp1.sys from the via-agp patch (4.04) from VIA.

I think we shouldn't look into the AGP part as it has nothing to do with the Promise harddisk controller I think.

My system doesn't hang... it corrupts registry info regularly when I shutdown without logging of first. The rest of the harddisk-info is in tact, no corruption problems there...
Anonymous
December 18, 2000 12:07:10 AM

While I have no solution,(sorry). I can at least offer some validity to your theory. Win9x has a similar problem using some combinations of the new faster cpu's and HDD's. The systems now shut down so fast, that the HDD doesn't have time to complete any writes that were pending. Dissabling the on board cache (don't know if it's possible) on the HDD may help. The data contained in the cache is reported to the os as "written" so is lost on a fast shutdown.
Anonymous
December 18, 2000 4:54:51 PM

Have you applied Win2K SP1 patch? Secondly have you disabled Byte Merged in the bios?

Before i disabled Byte Merge i had the same problem, after disabled it everything work fine.

My setup :
WIN2K + SP1, VIA AGP patch, AMD registry patch, VIA 4 in 1 4.25, DirectX 8, Detonator 6.49
A7V Bios 1005a, AGP4X, Fastwrite Enabled, Memory Optimal, "Byte Merge Disabled".
TB 1Gig@1.1 on FOB 38, 3 X 128 Meg Apacer VCM
2 x 30Gig Baracuda ATA100 on Abit Hot Rod Pro (Raid 0)
1 x 30Gig Baracuda ATA100 on Primary IDE
AOpen CDRom and ASUS DVDRom on Secondary IDE
Promise Controller disabled
Abit Siluro GTS 2 64Meg
SBLive Player on PCI 2
Abit HotRod Pro(Raid)(Bios and Driver 103) on PCI 3
3Com 905B Nic on PCI 5

The system is 100% stabil as i run prime 95 for 12 hours in back ground and running 3Dmark2000 1.1 on and off.
3DMark2000 1.1 is around 6860 @ 1024X768X16 Default.
December 19, 2000 5:56:14 PM

Win2k set my drives to PIO mode automaticaly, I hade to change the setting in the divise manager DMA which solved that problem for me.
!