Sign in with
Sign up | Sign in
Your question

IDC10 connector / DB9 wiring and PuTTY / RS232-to-USB converter

Last response: in Motherboards
Share
April 21, 2011 7:33:17 AM

Hi guys.

I have a problem with a serial connection on my ASRock 890GX Extreme 3, and I hope you guys can help me solve it.

I apologize in advance if I have overlooked any threads concerning my predicament, but I couldn't find any through the search option.

--- A little background information (for those wondering) ---
Recently I have been spending a fair bit of time messing with a Cisco Aironet 1130ag AP and after some time I got it all working like it should.
(Oh and just in case you're wondering - Cisco have made a device where the web GUI only(and i stress this: ONLY!) works with IE. How disappointing...)

Anyway - the configuring of said device has lead me to purchasing a RS232 to RJ45 converter cable in order to access the console port.
This is where the problem turns up! I need a serial (COM 9-pin) connector in order to use my converter, but I don't have one on the back along with the other ATX connectors.
After a little bit of searching i tried using an RS232-to-USB converter, but i was unable to get it working no matter how i tried. I got the drivers installed and my Win7 Ultimate (64-bit) recognises the device driver and makes a COM2 port, but no matter what, I cannot get any information through PuTTY.
Once again I did a little searching and found that other people had problems using an RS232 to USB converter, so i decided to leave the USB converter for a while. I have tested my RS232-to-TJ45 cable on a dedicated COM-port and I know that it's working just fine - so the problems is not the "cisco" cable.

Once again I tried asking Mr. Google, and I found that my board actually sports a native COM-port, BUT only through an IDC10-connector on the mobo instead of on the back of the mobo with the other connectors. What a relief - I can actually get a COM port from my computer, BUT I don't know if it actually works.
I went ahead and purchased a connector to fit the IDC10 connector on my mobo, and it's wired to a DB9 male plug (RS232-male) on the other end.
After this I figured, "yay! now it must work :) ", but no! I still can't get a connection through PuTTY (ver. 0.60.0.0) on the serial cable.

I'm using the "Cisco approved" connections of 9600baud, 8 bit data, 1 bit stop, no parity and no flow control.

This lead me to the conclusion, that the cable must be faulty, so i measured it through with a multimeter, and the connections are fine - however, I'm wondering if the actual wiring is correct.

And thus, I'm at my question :) 

--- Question begins here ---

How is the wiring from an RS232 male (DB9, connector) supposed to be wired to an IDC10- female connector?
As far as I can tell, the connectors are supposed to be wired like this (pin 1 to 1, 2 to 2, etc.):

DB9:
-----------------------
\ 1 | 2 | 3 | 4 | 5 /
\ 6 | 7 | 8 | 9 /
---------------
DB10:
----------------------
| 1 | 3 | 5 | 7 | 9 |
| 2 | 4 | 6 | 8 | X | (X = no connection)
----------------------

To me it looks like MY cable is wired like this:
(DB9 - IDC10)
1 - 1
2 - 3
3 - 5
4 - 7
5 - 9
6 - 2
7 - 4
8 - 6
9 - 8

I have no idea if the wiring is correct, but can anyone tell me if they have tried something similar? And perhaps where I can find a correct wiring diagram?
OR, has anyone had any success using an RS232-to-USB converter through PuTTY?

I know it's quite confusing and I might have messed things up in this ling thread, but can anyone help me?

Thanks in advance :) 
- Niels (from Denmark)

----------
The motherboard manual can be found here:
http://europe.asrock.com/downloadsite/manual/890GX%20Ex...
(mobo layout is on page 11)
April 21, 2011 8:22:19 AM

Bingo bongo! I solved it :) 

I swapped the wires and made sure the DB9 and IDC10 connector actually connected pin 1-1, 2-2 etc. and now it works!
The wires were connected wrong, and now my PuTTY connects like a charm :D 

Happy easter to everyone!
April 21, 2011 7:08:39 PM

Cool.
!