Sign in with
Sign up | Sign in
Your question

Seagate 2 TB External Hard Drive NOT Recognized on New Windows 7 PC

Last response: in Storage
Share
September 17, 2012 10:57:13 PM

Hello,
I've searched the forums and have not found that anything addresses my issue. I have a Seagate 2 TB External Hard Drive * THIS LINK For USB Hard Drive*. I built a new computer, with an AsRock Z77, Extreme 6 motherboard.

I installed Windows 7 Professional 64 bit, installed all drivers including USB 3.0 drivers from the motherboard manufacturer. The hard drive works great on my Windows XP old machine. It is NOT recognized at all on the new Asrock PC with Windows 7.

The new pc recognizes ALL of my other USB devices fine and they are seen in my Device Manager as well. Device manager does NOT see Other Devices, Unknown Devices or the Seagate Hard Drive at all. I have unplugged it, rebooted, plugged it in again. I've "Scanned for Hardware changes" under USB.

ONCE I got it to detect an Unknown Device but got a message that it was not recognized. I uninstalled it and it never came back again.

Here are my system details
Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)
Language: English (Regional Setting: English)
System Manufacturer: Asrock
System Model: Z77 Extreme 6
BIOS: BIOS Date: 03/05/12 18:29:25 Ver: 04.06.05
Processor: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz (8 CPUs), ~3.4GHz
Memory: 16384MB RAM
Available OS Memory: 16278MB RAM
Page File: 2833MB used, 29719MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

I apologize if this has been addressed before, but I honestly could not find this issue . .that is unresolved. Other threads claim the issue was resolved but I could not find any that solved my problem.

Thanks for your patience and time with this.

Sincerely,
J. Pentz
September 18, 2012 6:06:01 PM

Sorry for the bump. Here are the further details of what I did to troubleshoot:

. This drive works perfectly on my former computer. So, yes, it works very well on my other computer that had Windows XP professional on it. I simply swapped out the PC's from where the original PC was sitting. Unplugged the cables from the old and plugged them into the new pc. I moved none of the actual devices just unplugged cables from one and put then into the other new pc.

The reason I bought the external drive drive was to store and transfer my files to this new computer (windows 7) I recently built. All drivers were installed properly from the Asrock drivers and utilities disk. It supports USB 2.0 and 3.0.

Please know that in device manager, all USB device entries have no trouble. I have a webcam attached, and a keyboard and mouse that work very well. All are seen fine under USB in Device manager.

I am using a desktop that I built. This is the motherboard at the Asrock website. I updated the USB drivers from the manufacturer's website.
http://www.asrock.com/mb/overview.us.asp?Model=Z77%20Ex...

No, I did not try another USB cable because it worked fine on my other computer.

I am running Windows 7 Professional, 64-bit, with SP1 and all updates.

1. I have tried plugging the expansion drive into the USB port when the computer is on.

2. Tried booting up with the drive already plugged in.

3. Tried detecting it in Device manager.

4. I have tried plugging it in to several of the PC's other USB ports. They work for all other devices.

5. The external drive is on. Its warm (not hot) to the touch. I have checked all connections and they are firmly secure. I have tried reseating them.

6 I have tried the troubleshooting at this Seagate Link:
http://knowledge.seagate.com/articles/en_US/FAQ/201235e...
m
0
l
February 1, 2013 3:55:57 AM

I seem to experience this very same problem. I'm still working on mine but I belive it might be a result of not "safely removing" the hdd the last time it was still working or some short of corruption. I can hear my pc picking it up but nothing pops up. It might also be a driver issue but I'll get back to you if I figure it out
m
0
l
May 19, 2014 7:47:10 PM

I have ever tried to restore my wanted data back from my Seagate hard drive by following the suggestions of a related article:
icare-recovery.com/seagate-recovery/seagate-external-cannot-be-recognized.html
It also could be your chance.
Just never try to save all wanted data on only one drive again in the future.
m
0
l
Related resources
!