Sign in with
Sign up | Sign in
Your question

Windows 7 media player constantly updates

Last response: in Windows 7
Share
December 25, 2009 7:19:13 PM

Every time I open my media player it does this updating media library-even if I have added nothing new. This causes the processor to run very hard. it slows down all other operations!
a c 215 $ Windows 7
December 25, 2009 8:40:41 PM

This won't technically uninstall it, but try going to Programs and Features in the Control Panel, and click the "Turn Windows Features on or off" link. Expand Media Features folder and uncheck Windows Media Player. Reboot and go back to the same place, then check the box again. See if the issue continues.
January 3, 2010 11:20:09 PM

I tried turning media player off in this way but it did not help. I noticed that it happens when my internet browser is open(either firefox or explorer). With no browser open it will actually stop updating! It is annoying. It never happened with vista. I feel like going back. Help, please. Thanks
Related resources
January 14, 2010 1:40:15 AM

Still having the continual updating problem. Very annoying!
January 23, 2010 11:02:26 PM


I tried the things suggested on the thread and still have the problem. I would appreciate more input on how to solve this.
January 24, 2010 3:41:00 PM

franran26 said:
Every time I open my media player it does this updating media library-even if I have added nothing new. This causes the processor to run very hard. it slows down all other operations!




This is a bug in Media Player 11, it will happen in Win7, Win Vista, and WinXP, Microsoft is aware this is happening, I Googled and tracked down information about it, unfortunately when I discovered the solution I printed it out and didn't keep the link to the website with the solution.

I scanned and copied the solution that I had printed out and transferred it to Msft Word and copied and pasted it here, Hope this helps!


Quote:
Thanks too !!! Unbidden, for finding this link to google groups and thank you James Dooley for this fix

To exit that app, run (Note that "/Close" is case sensitive): "\Program Files\Windows Media Player\wmpnscfg.exe" /Close

To make it not run again, open the registry key using regedit

HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences\HME

and set the DWORD value DisableDiscovery to 2.

If you had a UPnP Media Renderer orcontrol point on your local network, you'd also be able to disable it by
right-clicking on its taskbar icon (which only shows if it finds a UPnP Media Renderer or control point)
and choose "Disable Future Notifications".

As to why it starts running when you've disabled media sharing, that's a bug in WMP 11 Beta2.



At least we know we're not infected some kind of virus as I've run Nortons, ESET, and the ESET online scanner and no infection is the results of the scans.

This is a very irritating problem that can bring your computer to its knees, MSFT needs to resolve this as soon as possible.
!