Sign in with
Sign up | Sign in
Your question

Error in IOCTL call

Last response: in Storage
Share
September 19, 2012 9:11:54 AM

Hello,

I wonder if anyone would help me with a potential problem please?

I was directed here from 'Ask', but the page with "Error in ioctl call usb drive" doesn't come up either here or (directly/usefully) in the site search.

The problem: my three-week old Seagate 2TB usb hard drive is working, but lately my free Easeus Partition Manager, when copying over old drives (onto and) around it, started displaying the above message title error for all the partitions on this drive, though still copying, and I'm worried about future failure. It doesn't do this with the other drives. The Easeus and Seagate sites weren't too useful about it.

There's some very old info on the web about drivers for usb sticks, but I thought I'd ask for some up-to-date advice.

It makes a few sudden 'spanging' noises, but otherwise is unnoticeable.

I've tried it on two pcs running XP home SP3 and Pro.

Thanks very much.

Regards,
Neville.

More about : error ioctl call

September 21, 2012 12:14:30 PM

kenrivers said:
You may have looked at these already but if not maybe they can shed some light on the rproblem.

http://www.tomshardware.com/forum/254097-45-error-ioctl...
http://www.tomshardware.com/forum/51966-45-error-ioctl-...
http://support.microsoft.com/?kbid=836618


Hi Ken, and thank you for replying.

No, I hadn't found those, but I don't get the STATUS_IO_DEVICE_ERROR as such, and nothing from Windows, so a bit wary about using a non-specific hotfix (I just get ERROR IN IOCTL CALL from the EaseUs program, and haven't heard from them or Seagate yet).

I've just worked through the 'update drivers' suggestion (Disk drives as well as USBs), but they're all up-to-date.

Thanks for the info, and if EaseUs or Seagate don't get back I'll look into the hotfix.

Cheers,
N.
!