Sign in with
Sign up | Sign in
Your question

XFX Card not being recognized

Last response: in Graphics & Displays
Share
June 7, 2010 3:29:43 PM

Hello, I have an XFX fanless card with Radeon HD 5450 (Cedar) GPU that wouldn't be recognized by the Mother Board (GIGABYTE GA-X58A-UD3R). Interestingly, the same PCI slot works fine with another older XFX fanless card with Nvidia chip. Neither Gigabyte nor XFX has replied with my technical request. Can any one advice if it's a DOA? Incidentally, Catalyst that came with the Car won't install properly either. It errored out during the installation.

When the new card with Radeon 5450 is installed, there is no signal coming from the card to the monitor as if it didn't exist at all. The monitor remained in the original standby mode.

your help is appreciated.

Jim

More about : xfx card recognized

a c 169 U Graphics card
June 7, 2010 4:14:56 PM

Hello and welcome to the forums :) 
What error does it exactly report ?
m
0
l
June 8, 2010 3:19:16 AM

Maziar: there wasn't any error message as the monitor won't even turn on. There isn't any signal from Video card to the monitor.

cheers,

Jim
m
0
l
Related resources
a c 169 U Graphics card
June 8, 2010 6:41:49 AM

I asked that because you said:
"Incidentally, Catalyst that came with the Car won't install properly either. It errored out during the installation"
Well can you test this card in another system ? and did you have any graphic cards before this one(on your X58 motherboard)?
m
0
l
June 8, 2010 10:08:48 AM

I installed an XFX card too tightly recently and got the same error as you, no monitor signal. Loosened the screw and it worked. Guess I was too excited to get it working.
m
0
l
June 10, 2010 12:23:24 PM

Maziar: The same PCI slot worked with other XFX card just fine - so I am assuming it's not the fault of the motherboard.

the Catalyst errored out during installation with a "file missing" message -

I do think the card is a DOA - but XFX has a horrible support system - one email from the technician in one week -



m
0
l
June 10, 2010 12:28:42 PM

Doive1231 - thanks - I'd try it to have the screw loosened. wish me luck.

m
0
l
!