Shuttle 500w powersupply

I just built a SX58J3 system identical the the system used in this review
http://www.hexus.net/content/item.php?item=25097

When i press the power button all I get is a click noise and some minimal fan movement. Im working overseas and all my power outlets are 220v. The 500w psu in the shuttle says its voltage rating is 100-240v but it also says select the right voltage, yet I dont see anyway to select 110 or 220.

does anyone have any idea what might be happening or how i can fix this problem. I have a 220 to 110 converter that I use for my xbox but its only rated at 300w and I wasnt sure if I would blow the fuse in it if I had tried to run the computer off it.
5 answers Last reply
More about shuttle 500w powersupply
  1. Back in the old days there used to be a red colored switch on the back of a power supply that allowed us to switch between 110 and 220. It was the same way with audio equipment. Modern psu's are able to do it automatically. If I'm not mistaken the automatic switching is a mandatory requirement in the European Union.

    Do you have an owners manual with technical specs and diagrams?
  2. unfortunetly the shuttle system came with only a quick install guide that was like a foldout poster. it does have a motherboard diagram but little info on the powersupply.

    I've tried powering up the system with out the disc drive, the hard drive and now with out the video card and all attempts are the same, a click noise and then nothing
  3. is there a little red switch on the psu?
  4. no, there are no switchs on the psu.

    here is the info page from shuttle on it
    http://www.shuttle.eu/products/xpc-accessories/pc63/
  5. Since you just built thesystem there might be a warranty. Have you tried contacting Shuttle?
Ask a new question

Read More

Power Supplies Shuttle Powersupply Power Components