Sign in with
Sign up | Sign in
Your question

Why is 4 gbs usable out of 8 gbs

Tags:
Last response: in Memory
Share
April 27, 2011 9:23:10 PM

I recently upgraded my computer to 8 gbs and got Windows 7 64-bit so I could run more RAM. The control panel says that only 4gbs are usable. I know its 64-bit and I've gone into the BIOS but could find no memory remapping or whatever its called.

Intel core i7 860 @ 2.80
G.Skill Ripjaws 8 gb
ASUS P7P55D-E LGA 1156 mobo
1TB
2x Radeon HD 5770

More about : gbs usable gbs

a b } Memory
April 27, 2011 9:56:21 PM

Are you using equivalent size ram modules? For example 2x4Gb or 4x2Gb
m
0
l
April 27, 2011 9:57:36 PM

2x4 gb
m
0
l
Related resources
a b } Memory
April 27, 2011 10:19:13 PM

Is windows showing "Installed Ram" correctly
Control Panel\System and Security\System - Installed memory (Ram)
Or is this under Windows task manager Performance Tab
Total
or
Physical memory available

My system Control panel shows I have 16 Gigs Ram Installed
BUT under Avalaible it only shows 6334 MB

In Bios, is the correct amount shown.

m
0
l
a b } Memory
April 28, 2011 1:05:03 AM

This might be a stupid idea, but you could try reinstalling the sticks, one at a time reboot and see if each show up as 4Gb and each one is functioning properly. Then be sure you have them installed in the color coordinated slots try the blue first then the black.
m
0
l
a b } Memory
April 28, 2011 2:03:48 AM

^ Not a stupid idea. And if Windows and Bios listing 4 gigs as installed - then your comment is very valid.

I had that problem, added a pair of sticks, Thought they were inserted go - nope.
Came up short, reinserted and all was well.

I'm just not sure if windows is seeing 8 gigs and saying 4 is usable, or is only seeing 4.
m
0
l
April 28, 2011 3:59:40 AM

In the BIOS I went to System Information and it said that 4085 of Memory is usable, but nothing about installed memory. In the task manager, it says that 4098 MB is in Hardware reserved and there is 4094 total. Installed it says that there is 8192 MB. Both sticks are plugged in, I tried that, I tried booting with one and then the other, and still no change.
m
0
l
April 28, 2011 4:11:54 AM

There are two factors to consider. First of all is having a 64 bit OS, second of all is having a chipset that supports more than 4GB of memory. Since you meet the first it may be that you have some limitation imposed in bios or your motherboard chipset that won't allow it to address the extra memory. For example, I have a Dell D620. I have a 64 bit OS, but my memory controller in hardware is 32 bit, so I only get 3.3 gigs out of 4. It might be something worth looking into. Hope this helps.
m
0
l
April 28, 2011 4:32:08 AM

How do I do that?
m
0
l
a b } Memory
April 28, 2011 12:36:34 PM

You have a P55 chipset, I think all P55 chipset, at least recognize upto 4 gigs per slot for a total of 16 Gigs, So hardware wise 4 x 2 gig sticks should be no problem.

Not withstanding some BIOS setting that is limiting you. Maybe someone with manual can have a look to see if there is a setting.

How about downloading CPU-z, install and run then post a snapshot of cpuz Memory tab. and spd tab. Use win 7 snipit tool for snapshot.
m
0
l
April 29, 2011 6:20:16 AM

I used the Snipping tool on both the memory and CPU tab of resource manager, is that what you wanted or is t the snapshot of CPU-z?
m
0
l
a b } Memory
April 29, 2011 12:31:21 PM

Snapshot of CPUI-Z. What does it show for Total installed, and on SPD page look at each slot, should show for slots.
m
0
l
April 29, 2011 8:56:27 PM

How do I put the picture on the thread? CPU-z says there is 8192 Mbytes under the memory tab, it also says there is a single channel under the Channel# one. Both of the slots that have the sticks (1 & 3) both read them and are exactly the same.
m
0
l
April 30, 2011 7:05:01 AM

I have a similar problem with my Maximus III Formula mobo. I just upgraded to Corsair Vengeance 16GB (4x4GB) DDR3-1600.
CPU-Z says 16GB, the mobo and Windows says there is only 8GB available to use.
My mobo supports 16GB.
m
0
l
a b } Memory
April 30, 2011 2:13:38 PM



(1) For Windows 7, use the snipping tool. Don't see, go to start/run box and type in snipping
Drag mouse over what you want to save, then save it.
go to: http://tinypic.com/
Follow instructions to upload image
When done
Highliter the link in "IMG Code for Forums & Message Boards" control C to copy link and control V to paste link in tom's box.

(2) back to problem:
You have two 4gig sticks, in the correct slots (1 and 3 I think double check manual on prefered slots.)
Under SPD slecting slot 1, or three should show the same info:
Size (4096), max bandwidth, manuf, part nr.
I have mine set to AMP-1600
Under Memory tab:
Type (DDR3)
Size (16384 Mine)
Channel # Dual ( if you have two Identical modules and this show single = Problem
NB Frew (mine = 3200), Basiclly 16 x bclk)
Bottom section: show show timings that are listed on SPD tab.
m
0
l
April 30, 2011 3:02:37 PM



that is of the memory tab,



that is of the SPD tab

Looks like it says the channel is only single, instead of double, so how can I change that?
m
0
l
a b } Memory
April 30, 2011 3:19:32 PM

Just to verify, You do have them in the correct slots. I have a gigabyte Board and for two sticks, daul channel. They must go into the 2nd and 4th slot counting from the slot closest to the processor. (Same colored) - On your board I think you have a pair of black and a pair of blue slots. If Asus used the same scheme, then that would be the two blue slots. - Your MB manual should specify which slots are prefered. Bottom line is they should not be next to each other, they should be in alternate slots.
m
0
l
May 1, 2011 6:37:12 AM

They're both in the blue slots. They're not 2nd and 4th from the processor, they're 1st and 3rd, so should I change them to in the black slots instead then?
m
0
l
a b } Memory
May 1, 2011 4:01:04 PM

What does your MB manual state - does it indicate a preference?

You can always try the other pair of slots..

Comparing your Memory tab (How the memory is set-up) vs what is stored on the Ram is not the same - should look like column. labled XMP-1334.
On my system, my memory tab is Identical to XMP-1600 column.

Looked @ newegg, could not see your ram. Your Part Number shows:F3-10666CL7-4GBRH. Your XMP cloumn shows 7.0,8,8,23
On Newegg all the F3-10666CL7 all show timings of 7.0,7,7,21
Look on the package, or module an note the Part Number.
Use caution when handleing memory, Play it safe ant touch the computer case before handling.

Have you looked at the Bios section in your MB.
Is there a Memory line item that has "use XMP", if so you can try this, it should "force" the values (timing/voltages) to the correct values.

Don't have your MB (have gigabyte), I think you have to register to download your manual. Will do later today.
m
0
l
May 2, 2011 11:03:16 AM

Okay thanks. I went into the MB and there is nothing to do in there with memory. So I'm not sure. I haven't tried the other slots but I will later.
m
0
l
a b } Memory
May 2, 2011 3:10:05 PM

OK, let’s drop back 50 yards and punt like HE double L.

(1) Looking @ manual your memory should be in the 2 and 4 the slot (counting from one nearest the CPU (This would be A1 and B1 slots)
(2) What is the status of your mem ok led – should be off.
(3) What is your current Bios version (can find on CPU-Z Mainboard tap. When having a problem it is always a good idea to have the latest Bios version.
...A) There are 3 versions of the P7P55D-E. Deluxe Latest bios is 1504, the Pro Latest Bios 1602 and the Premium, didn’t look up. MAKE sure you get the right one.
..B) To update bios if you do not have latest – follow Para 3.2.2 in manual (Asus EZ Flash 2 Utility.
..C) BEFORE updating Bios, as you are having a memory problem, I would recommend that you download Memtest 86.iso and make a bootable ISO disk with memtest on it – boot to disk and run for at least 2 hours. If you have any mem errors, remove memory stick from B1 and just use the one in A1. Retest, should be OK.
(4) After updating the Bios see if this fixed your problem (boot to win 7 and check memory status)

(5) Still have a problem.
..A) Is mem LED on, if so try using Mem ok (sec 2.6 in manual.
..B) Try loading XMP; this is located in bios under the AI Overclocker Tuner (Section 3.5.2 of manual.

Added: link to metest86 ISO http://www.memtest86.com/download.html
m
0
l
May 3, 2011 7:24:42 AM

The sticks are in the right slot.
The Mem-ok light is off
My BIOS version is 1002 and is quite out of date. I installed the ASUS update utility but when I ask it to search for a server to download the new BIOS update from it will search but never find one. So I'm in the process of downloading the new version off the website.
Is the memtest neccesary?
m
0
l
a b } Memory
May 3, 2011 12:47:01 PM

On memtest, In my opionion - Yes.
Reason: Memory is inbetween HD and bios. When the Bios file is read it is transfered to memory first. The cpu acts as a director to send it to the Bios CMOS. If you have a memory error this incorrect data could be sent to the Bios, end result is an error in the bios and in worst case could make "brick" your CMOS Bios chip.

Myself: On a new system I always run memtest befor updating the bios and/or before installing the operating system. When ever I make a change to bios that effects the memory, or add/change out a memory stick, I rerun memtest before allowing the system to boot to operating system. In this case a meory error could result in a hosed operating system.

An alteranative would be to download prime 95 and run that (would not have to make an Iso boot disk, unless prime 95 detected errors. I find prime95 better at detecting memory errors. Run it in Blend mode, normally default, and run for atleast one hour.
Also when I run Prime 95 I also monitor temps and voltages. For this I use CPUID HWMonitor. Inaddition to testing memory and cpu stability, Prime95 is offten used to verify that the cpu will not overheat and that the PSU is good.

HWMonitor
http://www.cpuid.com/softwares/hwmonitor.html
Prime 95
http://www.mersenne.org/freesoft/
or
http://majorgeeks.com/Prime95_d4363.html
m
0
l
May 3, 2011 10:04:16 PM

Okay so I downloaded Prime95 and ran it, it opened 9 small windows and isnt doing anything. If I go to test though it says stop, and continue is greyed out, does that mean it is running properly?
m
0
l
a b } Memory
May 4, 2011 3:04:54 AM

I only get 5 windows I5-750 4 cores, 4 threads.
You will have a main window (at top), then one window per thread (4 cores + 4 hyperthreads).
There is no indicator that shows it is working.
But:
Will show Top window "starting workers"
In Worker Windows It will show Date time and Test Number (starting at 1)
The test # will increment and if you get a error it will display it and stop that worker.

PS: if you have HWMonitor running you will see the temperatures of all four cores going up (Should monitor) themps will come close to the max value within about 15 min, after that you can kind of walk away, go what TV and jest peek at it every 15 min to make sure temps are not getting to high.
m
0
l
May 4, 2011 4:21:09 AM

Well I let it run for a few hours and there has yet to be any error reports. I assume that means that the memory is fine? Do you want me to post a snapshot of it? I'm not at home tonight so I can tomorrow. I guess since everything basically works, I'll probably have to update the BIOS then because that seems to be the only thing that would cause this problem.
m
0
l
a b } Memory
May 4, 2011 12:44:36 PM

Good on the - No errors.
Yes, update the bios.
Make sure you pick the right Model and Just follow Para 3.2.2 in manual (Asus EZ Flash 2 Utility).

Added: saw in another post that the Thumbdrive should be " FAT-32 formatted USB Flash Drive"
m
0
l
May 5, 2011 6:42:27 AM

So I just updated the BIOS through the ASUS Update Utility, exactly the way it told me to in para 3.2.3. Still no change. I went into the BIOS after the update and it still reads usable memory at 4096mb or whatever it is. In the task manager it reads as 4 available and 4 in hardware reserve, and in the control panel it reads at 8.00 gbs with only 4 usable. Very strange. The sticks work too I suppose. Should I try and put them in the black slots instead?
m
0
l
May 5, 2011 6:51:45 AM

can you try one stick at a time ? how has no one suggested this yet....

memtest them individually with a memtest boot cd that you will need to burn
m
0
l
May 5, 2011 7:06:25 AM

Well good news, I swapped out the ram sticks into different slots and voila. The BIOS recognizes them. I start up and the control panel sees it as 8.00, the task manager sees it properly too. I suppose there was something going on with the BIOS version, because I had tried to swap out the sticks before the update and nothing worked, reseated them and so on. Now it works after the update, so I don't know what was different, but whatever it is it works. Thanks everyone for your help, it was great!
m
0
l
May 5, 2011 7:49:51 AM

good news. good work. Quite often bios revisions add support for different memory modules from a variety of vendors. I also have 8gb ripjaws
m
0
l
a b } Memory
May 5, 2011 12:56:46 PM

Great!
Did you also verify that it is running in dual channel mode (Most likely is).
Cpu-z memorry tab.
Take care and enjoy.
m
0
l
!