Sign in with
Sign up | Sign in
Your question

SSD showing as IDE in BIOS - boot priority

Last response: in Storage
Share
September 22, 2012 8:22:25 AM

Hi,

I just installed a Samsung 830 256GB SSD. This is supposed to be my boot drive. In BIOS I set the SATA controllers to AHCI and did a clean installaltion of windows. Now I am using the Asus P7P55D-E Pro Motherboard. This board has only got two 6Gb/s Sata ports and they are under control of a Marvell chip.

So...because I had not set the BIOS setting on-board-devices -> Marvell -> AHCI but instead left it in IDE (which was default) my SSD shows up in th eboot priority as IDE: SAMSUNG etc.

I checked online and since I did an installation of windows in AHCI mode (regedit shows value 0 in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\msahci)
I figured I might as well just try and change the setting of the above mentioned marvell controller.

Windows boots fine and the " experience index " increased from 7.5 to 7.8. however, the drive still shows up as IDE: SAMSUNG ... in the boot priority menu.

My Questions are:

1) Why is that? Is the drive controlled by AHCI or IDE (how to test)?

2) I read elsewhere that people advised not to use the Marvell Sata ports as boot ports. But these are the only 6GBs ports on my motherboard - What is your opinion? Accept (not further specified) stability issues with the Marvel ports or go with 3GBs Intel Sata ports?

Thanks a million.
a b G Storage
September 23, 2012 2:43:36 PM

If the BIOS is set to IDE, then no driver in windows will allow you to use it AHCI. The setting in BIOS is the top priority.

If you have the correct setting in the BIOS and the correct drivers for the Marvel controller, and it works as expected, it doesn't matter what anyone says.
a c 124 G Storage
September 23, 2012 3:17:34 PM

Which way do you feel better?
!) Get the good SATAII score in the SATA II port.
2) Get the lower score in the SATAIII port and act like the SATAII.
!